Upload_max_filesize ignored - bug or feature?


I just installed Nextcloud 11.0.1 on an ubuntu 16.04.1 LTS server with apache webserver. The config files and the webinterface show 511 MB as max file size for uploading but I had no problems uploading a file 6+ GB through webinterface (Win10 Prof x64, tested with IE, Edge and Chrome). Now I am wondering if this is a bug or a feature (I think I read somewhere else, that this setting might be ignored as long as the user quota and the disk have enough space for saving bigger files)?

Kind regards,

I believe that it should be a feature of the WebUpload HTML API that was recently introduced. It should allow upload of any sized files as long as their is sufficient disk space.

Keep in mind that not all browsers support this feature.

Sounds good - but is there any way to disable the new behaviour? If not I am not too sad but my boss prefers the old way…

As far as I know, I don’t believe there is, apart from manually disabling the API in the browser or editing the code to revert to normal.