Upload error via web interface

Hello Dear Community,
I have a dedicated server running Nextcloud 12.0.3 on it. It also works in and of itself.
I’m just having some minor technical difficulties.

So the server is a:
Debian 9.1 Server
nginx/1.12.1
PHP7-fpm
ISPConfig 3.1.7p1
bind9

What works. I can use the “Sync your data” apps for desktop and Android to store and delete files on the cloud. Absolutely no problem.

Which doesn’t work. When I try to save files via the browser, it doesn’t work. It is said (something like this, at least):
You want to save a 1.5 MB file but there is not enough free space available. 0Bytes

I don’t get any error messages in the log files everything seems to work smoothly.
The only thing I get in the Acces. log is this when I upload a 0-byte file:

xxx. xxx. xxx. xxx. xxx - - - -[07/Oct/2017:19:51:13 +0200]"GET /core/preview. png? file=%2F%2FNew+textdocument+ (3. txt&x=96&y=96&c=cec4c966d8800212d3719faacfb773c2&forceIcon

xxx. xxx. xxx. xxx. xxx - - - -[07/Oct/2017:19:51:16 +0200]“PUT /remote. php/webdav/New%20Textdocument%20 (3). txt HTTP/1.1” 204 0 “-”"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like
77.21.32.94 - - -[07/Oct/2017:19:51:16 +0200]“PROPFIND /remote. php/webdav/New%20Textdocument%20 (3. txt HTTP/1.1” 207 902 “-”"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like G

xxx. xxx. xxx. xxx. xxx - - - -[07/Oct/2017:19:51:20 +0200]“GET /ocs/v2. php/apps/notifications/api/v2/notifications HTTP/1.1” 200 1484 “-”"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like G

When I upload a 1.6MB file I only get the message “there is no storage space”. There are no entries in the logs.

However, Nextcloud tells me in the log that:

Zend OPcache can’t be temporary enabled (it may be only disabled to the end of request) at Unknown#0

and

GuzzleHttp\Exception\ExceptionRequestException: cURL error 18: transfer closed with 26500 bytes remaining to read

But what I find amazing is that I can upload a 0Byte file without any problems.

I also noticed that I can’t install apps automatically through the web interface. I guess it’s also because of this problem.

Here’s my VHost for Nginx:

# Add headers to serve security related headers
add_header X-Content-Type-Options nosniff;
#add_header X-Frame-Options "SAMEORIGIN";
add_header X-XSS-Protection "1; mode=block";
add_header X-Robots-Tag none;
add_header X-Download-Options noopen;
add_header X-Permitted-Cross-Domain-Policies none;

location = /robots.txt {
		allow all;
		log_not_found off;
		access_log off;
}

# The following 2 rules are only needed for the user_webfinger app.
# Uncomment it if you're planning to use this app.
#rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
#rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json
# last;

location = /.well-known/carddav {
		return 301 $scheme://$host/remote.php/dav;
}
location = /.well-known/caldav {
		return 301 $scheme://$host/remote.php/dav;
}

# set max upload size
client_max_body_size 8G;
fastcgi_buffers 64 4K;

# Disable gzip to avoid the removal of the ETag header
gzip off;

# Uncomment if your server is build with the ngx_pagespeed module
# This module is currently not supported.
#pagespeed off;

location = / {
		index index.php index.html;
}

location / {
		rewrite ^ /index.php$uri;
}

location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
		deny all;
}
location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
		deny all;
}

location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/t$/40[34])\.php(?:$|/) {
		fastcgi_split_path_info ^(.+\.php)(/.*)$;
		include snippets/fastcgi-php.conf;
		fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
		fastcgi_param PATH_INFO $fastcgi_path_info;
		fastcgi_param HTTPS on;
		#Avoid sending the security headers twice
		fastcgi_param modHeadersAvailable true;
		fastcgi_param front_controller_active true;
		#fastcgi_pass php-handler;

{FASTCGIPASS}
fastcgi_intercept_errors on;
fastcgi_request_buffering off;

		# Cache
		#fastcgi_cache_bypass #skip_cache;
		#fastcgi_no_cache $skip_cache;
		#fastcgi_cache cloud.ryztec.com;
		#fastcgi_cache_valid  60m;
		#fastcgi_cache_methods GET HEAD;
}

# Cache purging
fastcgi_cache_key $http_cookie$request_method$host$request_uri;
fastcgi_cache_use_stale error timeout invalid_header http_500;
fastcgi_ignore_headers Cache-Control Expires Set-Cookie;

location ~ ^/(?:updater|ocs-provider)(?:$|/) {
		try_files $uri/ =404;
		index index.php;
}

# Adding the cache control header for js and css files
# Make sure it is BELOW the PHP block
location ~* \.(?:css|js|woff|svg|gif)$ {
		try_files $uri /index.php$uri$is_args$args;
		add_header Cache-Control "public, max-age=7200";
		# Add headers to serve security related headers (It is intended to
		# have those duplicated to the ones above)
		# Before enabling Strict-Transport-Security headers please read into
		# this topic first.
		add_header Strict-Transport-Security "max-age=15768000";
		#  includeSubDomains; preload;";
		add_header X-Content-Type-Options nosniff;
		add_header X-Frame-Options "SAMEORIGIN";
		add_header X-XSS-Protection "1; mode=block";
		add_header X-Robots-Tag none;
		add_header X-Download-Options noopen;
		add_header X-Permitted-Cross-Domain-Policies none;
		# Optional: Don't log access to assets
		access_log off;
}

location ~* \.(?:png|html|ttf|ico|jpg|jpeg)$ {
		try_files $uri /index.php$uri$is_args$args;
		# Optional: Don't log access to other assets
		access_log off;
}

Before I forget to mention it. the same configuration works with Apache.

Could it be due to the CHMOD settings?
I mean, ISPConfig creates users and groups, for example:
Group: client1
Owner: web1
Is it because of the permissions that php7-fpm cannot access it?

Hallo Liebe Community,
ich habe ein dedizierten Server mit Nextcloud 12 drauf laufen. Es funktioniert auch an und für sich.
Ich habe nur ein paar kleine technische Schwierigkeiten.

Also der server ist ein:
Debian 9.1 Server
nginx/1.12.1
PHP7-fpm
ISPConfig 3.1.7p1
bind9

Das was funktioniert. Ich kann mit den Apps “Sync your data” für Desktop und für Android Dateien auf der Cloud speichern und löschen. Absolut kein Problem.

Was nicht funktioniert. Wenn ich über den Browser versuche Dateien zu speichern funktioniert das nicht. Es wird gesagt ( so ähnlich zumindest ):
Sie möchten eine 1,5 MBgroße Datei Speichern es ist aber nicht genug freier Speicher vorhanden. 0Bytes

Ich bekomme keine Fehlermeldungen in den Log Dateien alles scheint reibungslos zu funktionieren.
Das einzige was ich bekomme ist in der Acces.log folgendes wenn ich eine 0 Byte große Datei hochlade:

xxx.xxx.xxx.xxx - - [07/Oct/2017:19:51:13 +0200] “GET /core/preview.png?file=%2F%2FNeues+Textdokument+(3).txt&x=96&y=96&c=cec4c966d8800212d3719faacfb773c2&forceIcon=0 HTTP/1.1” 404 1806 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36”

xxx.xxx.xxx.xxx - - [07/Oct/2017:19:51:16 +0200] “PUT /remote.php/webdav/Neues%20Textdokument%20(3).txt HTTP/1.1” 204 0 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
77.21.32.94 - - [07/Oct/2017:19:51:16 +0200] “PROPFIND /remote.php/webdav/Neues%20Textdokument%20(3).txt HTTP/1.1” 207 902 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36”

xxx.xxx.xxx.xxx - - [07/Oct/2017:19:51:20 +0200] “GET /ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1” 200 1484 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36”

Wenn ich eine 1,6MB große Datei hochlade bekomme ich nur die Meldung “das kein Speicherplatz da ist”. In den Logs enstehen keine Einträge.

Allerdings sagt mir Nextcloud im Protokoll folgende Meldung:

Zend OPcache can’t be temporary enabled (it may be only disabled till the end of request) at Unknown#0

und

GuzzleHttp\Exception\RequestException: cURL error 18: transfer closed with 26500 bytes remaining to read

Was ich aber erstaunlich finde ist das ich eine 0Byte große Datei hochladen kann ohne Probleme.

Desweiteren ist mir aufgefallen das ich durch das WebInterface auch keine Apps automatisch Installieren lassen kann. Ich vermute das es auch an diesem Problem liegt.

Hier ist erst einmal meine VHost für Nginx:
watch above
Bevor ich es vergesse zu erwähnen. die gleiche Konfiguration funktioniert mit dem Apache.

Kann es eventuell an den CHMOD Einstellungen liegen?
Ich meine ISPConfig legt ja User und Gruppen an zum Beispiel:
Gruppe: client1
Eigentümer: web1
Liegt es eventuell an den Berechtigungen das php7-fpm nicht darauf zugreifen kann?

Ich hatte global/restrictions.conf in nginx aufgenommen. Dies beinhaltet eine Anweisung, um die Ausführung von .php-Dateien in einem Upload-Verzeichnis zu verbieten… jetzt funktioniert es wie gewollt.