Upload big size file (>4gb)

Hi all,
I have been reading forums and posts on this problem for days, but I don’t find anything interesting, only one post was “resolutive”, “flowupload” was proposed as an alternative, and I must say that it works even if it is really very slow.
I have been testing my new NC installation on raspberry pi 4 model B 4 GB for about 2 months, in recent months I have done a bit of “troubleshooting”, trying to fix my new “private cloud”, unfortunately the only problem I can’t to solve is that of uploads greater than 4GB, the interface loads the whole file, and when it processes it I get an error, I had a similar problem with the download of the folders (creation of the .rar), which I solved by setting the compression of folders into files .tar, now I can download everything, but for the upload I don’t know how to resolve it, yes I found “FlowUpload” but it is very slow, I’d like to solve the error, in order to load the files from GUI at maximum speed (I state that on php file I set 90GB as maximum upload and download size).

Error: Cannot modify header information - headers already sent by (output started at /mnt/usbhdd/nextcloud/3rdparty/sabre/http/lib/Sapi.php:132) at /mnt/usbhdd/nextcloud/apps/dav/lib/Connector/Sabre/File.php#691

Sabre\DAV\Exception: Error while copying file to target location (copied bytes: -1, expected filesize: -1 )


Nextcloud version : 20.0.7
Operating system and version : Raspberry pi OS 32Bit
Apache or nginx version : Apache/2.4.38 (Raspbian)
PHP version : 7.3.19

The issue you are facing:

Is this the first time you’ve seen this error? : Yes

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxxx',
  'passwordsalt' => 'xxxxxxx',
  'secret' => 'xxxxxxxx',
  'trusted_domains' => 
  array (
    0 => '192.168.1.2',
  ),
  'datadirectory' => '/mnt/usbhdd/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '20.0.7.1',
  'overwrite.cli.url' => 'http://192.168.1.2/nextcloud',
  'dbname' => 'nextclouddb',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'pippo',
  'dbpassword' => 'password',
  'installed' => true,
  'twofactor_enforced' => 'true',
  'twofactor_enforced_groups' => 
  array (
  ),
  'twofactor_enforced_excluded_groups' => 
  array (
  ),
  'mail_from_address' => 'pippor',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'outlook.it',
  'mail_smtphost' => 'smtp.office365.com',
  'mail_smtpport' => '587',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauth' => 1,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpname' => 'pippo@outlook.it',
  'mail_smtppassword' => 'password',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 1.5,
  ),
);