Upgrate problem from 16.0.8 to 17.0.3

Hello evrybody,

My Nextcloud is installed on a shared hosting.
I launched the upgrade procedure via the 16.0.8 updater. The process went well (no error message).
At the end of the file replacement process, I normally returned to the Nextcloud homepage. There, no page loads and the update doesn’t happen.
Should index.php be launched, or another file?

Thank you for your help.


Please check the log file your hoster is providing you.

I have access to acces.log.
What should I be looking for?

Error.log would be more interesting.

For error messages or other conspicuous messages.

I’ve enabled php error messages. When launching the URL of my site, I get the following error:
Fatal error: Cannot redeclare getallheaders() in /home/httpd/e/r/i/eric-jr/n.hfn.re/3rdparty/ralouphie/getallheaders/src/getallheaders.php on line 10
What is this file used for?

Hello @EricJR,

please use search engines and use the support of your shared hosting provider.

For this specific message I cannot help you.

Hello @EricJR,

I have the same problem and maybe the information from my error log is more useful for you to identify the problem.

PHP Fatal error: Declaration of OCA\\GroupFolders\\Versions\\VersionsBackend::getVersionFile(OCP\\IUser $user, OCP\\Files\\FileInfo $sourceFile, int $revision): OCP\\Files\\File must be compatible with OCA\\Files_Versions\\Versions\\IVersionBackend::getVersionFile(OCP\\IUser $user, OCP\\Files\\FileInfo $sourceFile, $revision): OCP\\Files\\File in /var/www/nc_stpeter/apps/groupfolders/lib/Versions/VersionsBackend.php on line 38

@rakekniven @fcadmin
I solved the issue by renaming the “getallheaders()” command in the getallheaders.php file on line 10, to something else not used, for example “zutblahblah_getallheaders()”.
It seems to be a specific problem of PHP 7.3.
After the update, it does not seem to be necessary to do the reverse manipulation. I haven’t done it and I haven’t noticed any malfunction for several days.

I hope it will be usefull for you!

Thank You for this solution.
In the meanwhile I solved the problem by installing a fresh Nextcloud 17.0.3 and restoring data and config folders as well as the db from my backup. When I navigated to the page the incomplete upgrade process resumed and has been finished without errors. After that I was able to upgarde to Nextcloud 18 without any problem.