Upgrading NextcloudPi from 1.15.3 to 1.18 problems…

getting this error when downloading the packages:

The repository ‘http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal Release’ does not have a Release file.

any guesses?