Upgrading from oc 9.0.4

I’ve done an upgrade marathon from oc 9.0.4 to nc 11. Now the login page looks like this:

File not found
The specified document has not been found on the server.
You can click here to return to Nextcloud.

I get no login form. That’s all. No matter which page I try to open.

I’ve set the debug level to “ALL” and get no info in the nextcloud.log. I see no error in the apache.log… Is there any possibility to get more information WHICH file is not found?

Nextcloud version: 11.0.2
Operating system and version: Ubuntu 14.04
Apache version: 2.4.7
PHP version: 7.0.16

For me this looks more like you open a specific file hosted on Nextcloud that does not exist any more. Apache has also an error.log.

The URL I’m calling is:


error.log is not reporting any error when I’m accessing the page.

For some reason the login page is not found?!?!? I have no clue.

I found the integrity chech: I ran the ‘occ integrity:check-core’:

~/www/oc# sudo -u www-data php occ integrity:check-core

    • .htaccess:
      • expected: 11e2db30f0cf23df1b5aa1cdf329a8c88d253f86e43f9e7af1b30969eb0175030103b138e2f7ab7608c902bbb57a5d578c2c0ca09f3abf2ef83415f4bc6f6e20
      • current: cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e

If I use the .htaccess file from the tar.bz instead I get:

Not Found
The requested URL /oc/login was not found on this server.

It’s solved: The .htaccess was crap. I copied the latest .htaccess from the .tar.gz and ran

sudo -u www-data php occ maintenance:update:htaccess
1 Like