Upgraded to nextcloud 11

Files app is the only on working correctly.
Contacts shows nothing. Not even settings is working.
Calendar is not working at all either. almost everything comes up with {{ something }}. There is nothing in the caldav address section.

Also after the upgrade, I am not getting this error again.

This server has no working Internet connection: Multiple endpoints could not be reached. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.

Any suggestions?

Please provide more details about your upgrade, from which version you´re coming, where all the apps diabled while you performed the upgrade, did you start the upgrade via browser or using cli using ./occ?

Just a guess: It looks like your Installation contains unaltered Data in the DB, if you have a backup of your DB disable the Apps, and enable them one by one. When you enable the app it will scan for needed changes in the DB and move nextcloud to Maintenance-Mode. If your Calendar and other apps contain a huge amount of data you should start the maintenance from commandline using occ.

Dear Hardcoded,

interesting for me to know as well: should I - as a general rule - disable or stopp all apps before i perform an upgrade? because i am still on 10, trying to make shure everything will go well when i move to 11…

Hi Lex, maybe the manual upgrade guide for nextcloud 11 is helpful to get some details: https://docs.nextcloud.com/server/11/admin_manual/maintenance/manual_upgrade.html

The recommended path for the upgrade is renaming the old nextcloud folder for backup purposes and start with a clean install from nextcloud 11 package, you´re only importing the old config.php and reuse the existing (and hopefully backuped :wink: ) database. For the upgrade from nc10 to nc11 it´s neccessary to remove all the old files located in nextcloud path, excepting the config.php and all content of the /data/ directory (where the user files are stored). Following that scenario only a few stock apps are active when the upgrade is finished, calendar and many more must enabled manually after the upgrade process is finished. Whenever one of these fresh enabled apps recognize Data in the DB which need attention the instance is switching to maintenance mode. If you have a lot of data in address book, calendar etc. you should start the upgrade process using command line occ command to avoid timout issues for scripts running in context of the webserver (often 300 seconds).

I´m really fresh to nextcloud and upgraded my productive ownCloud 8 Instance to nc9, nc10 finally to nc11. Disabling all apps before upgrading was a general recommendation in context of ownCloud - meaning i´m really not sure if this is still neccessary for nextcloud upgrades in general. :wink:

Ok, I am on a hosted enviroment, so i dont know if i can go for any command line stuff… thanks for the input though, i will keep waiting a few days to see if there is some NC 11.x in the wings and then probably go for it…

Sorry had a honey to do list to complete before the night was over.

I could not get it to recognize 11 from 10. So I deleted everything and
started over. I download the nexcloud server from the git hub. expanded
that in to my owncloud directory where I keep my server. I copied my
config.php file over. went to the web page. It would not let me do
anything. It then told me that it was upgraded. I enabled apps one at a
time. It said it was upgrading and never changed the screen but the
version in the console was different and the app was enabled. I am going
to delete everything right now and try it again.

Thanks,

Ryan (KB8PMY)
KD8TUZ Hamilton Wireless Radio Club

Okay… I got it to work.

I removed everything again. Then I ran occ before I even went to the
webpage. Now it works.

Thanks,

Ryan (KB8PMY)
KD8TUZ Hamilton Wireless Radio Club

So after I got it working and reloaded everything. I now get service
unavailable. No matter if you use the web gui, apps, or desktop app.
I looked at the log file amd only gives me a 503 error.

Thanks,

Ryan (KB8PMY)
KD8TUZ Hamilton Wireless Radio Club