Upgrade to 28 - Admin Overview not seeing sodium module installed

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud 28.0.1
Archlinux: 6.6.10-arch1-1
Apache / 2.4.58 (Unix)
OpenSSL / 3.2.0
PHP / 8.1.27

The issue you are facing:

This may be a regression as it is similar to Missing PHP Module sodium from Ver. 22 days.

After upgrade to 28 (from 27) the Admin->Overview check recommended:

This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them: sodium. For more details see the documentation ↗.

So I installed php-sodium and enabled the module – and confirmed it was enabled in php:

# php-legacy -m | grep -i sodium
sodium

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Update to 28.0.1 from 27.0.4
  2. Check Admin->Overview, complains php-sodium not installed
  3. Install/Enable php-sodium
  4. It doesn’t fix 2. above

The output of your Nextcloud log in Admin > Logging:

{"reqId":"qdaVUkWP6Fk2fSmvcmPe","level":3,"time":"2024-01-13T03:36:49+00:00","remoteAddr":"192.168.6.104","user":"david","app":"PHP","method":"GET","url":"/nextcloud/ocs/v2.php/search/providers?from=%2Fnextcloud%2Fsettings%2Fuser%2Fsecurity","message":"Module \"apcu\" is already loaded at Unknown#0","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.1.1","data":{"app":"PHP"}}
{"reqId":"QSQfhG45OFYMRneu7dA5","level":3,"time":"2024-01-13T03:37:19+00:00","remoteAddr":"192.168.6.104","user":"david","app":"PHP","method":"GET","url":"/nextcloud/apps/theming/theme/light.css?plain=0&v=c973a648","message":"Module \"apcu\" is already loaded at Unknown#0","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.1.1","data":{"app":"PHP"}}
{"reqId":"jm3fAimSuEIaZlpT9Xhg","level":3,"time":"2024-01-13T03:37:43+00:00","remoteAddr":"192.168.6.104","user":"david","app":"PHP","method":"GET","url":"/nextcloud/ocs/v2.php/search/providers?from=%2Fnextcloud%2Fsettings%2Fadmin%2Flogging","message":"Module \"apcu\" is already loaded at Unknown#0","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.1.1","data":{"app":"PHP"}}
{"reqId":"Dtj1pNTnQCSjuoYdfSJ0","level":3,"time":"2024-01-13T03:43:08+00:00","remoteAddr":"192.168.6.104","user":"david","app":"PHP","method":"PROPFIND","url":"/nextcloud/remote.php/dav","message":"Module \"apcu\" is already loaded at Unknown#0","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.1.1","data":{"app":"PHP"}}

Nothing but the annoying "message":"Module \"apcu\" is already loaded at Unknown#0" that has been there since my first Nextcloud install.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

{
    "system": {
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "logfile": "\/var\/log\/nextcloud\/nextcloud.log",
        "default_locale": "en_US",
        "default_phone_region": "US",
        "knowledgebaseenabled": true,
        "apps_paths": [
            {
                "path": "\/usr\/share\/webapps\/nextcloud\/apps",
                "url": "\/apps",
                "writable": false
            },
            {
                "path": "\/var\/lib\/nextcloud\/apps",
                "url": "\/wapps",
                "writable": true
            }
        ],
        "trusted_domains": [
            "localhost",
            "host.domain.tld",
            "192.168.6.111"
        ],
        "overwrite.cli.url": "https:\/\/2pi.3111skyline.com\/nextcloud",
        "htaccess.RewriteBase": "\/nextcloud",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "28.0.1.1",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "smtp",
        "mail_sendmailmode": "smtp",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "25",
        "maintenance": false,
        "app_install_overwrite": [
            "issuetemplate",
            "holiday_calendars"
        ],
        "theme": "",
        "loglevel": 2,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "filelocking.enabled": true,
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 0,
            "timeout": 0
        }
    }
}

The output of your Apache/nginx/system log in /var/log/____:

[Fri Jan 12 21:18:03.762302 2024] [core:notice] [pid 423] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
[Fri Jan 12 21:21:14.243651 2024] [mpm_prefork:notice] [pid 423] AH00171: Graceful restart requested, doing restart
[Fri Jan 12 21:21:14.311406 2024] [mpm_prefork:notice] [pid 423] AH00163: Apache/2.4.58 (Unix) OpenSSL/3.2.0 PHP/8.1.27 configured -- resuming normal operations
[Fri Jan 12 21:21:14.311432 2024] [core:notice] [pid 423] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
[Fri Jan 12 21:22:21.970102 2024] [mpm_prefork:notice] [pid 423] AH00171: Graceful restart requested, doing restart
[Fri Jan 12 21:22:22.060488 2024] [mpm_prefork:notice] [pid 423] AH00163: Apache/2.4.58 (Unix) OpenSSL/3.2.0 PHP/8.1.27 configured -- resuming normal operations
[Fri Jan 12 21:22:22.060513 2024] [core:notice] [pid 423] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'
[Fri Jan 12 21:43:00.293497 2024] [mpm_prefork:notice] [pid 423] AH00171: Graceful restart requested, doing restart
[Fri Jan 12 21:43:00.371804 2024] [mpm_prefork:notice] [pid 423] AH00163: Apache/2.4.58 (Unix) OpenSSL/3.2.0 PHP/8.1.27 configured -- resuming normal operations
[Fri Jan 12 21:43:00.371831 2024] [core:notice] [pid 423] AH00094: Command line: '/usr/bin/httpd -D FOREGROUND'

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

None

How do I satisfy the warning that sodium is really installed?

This appears to have been an Archlinux packaging issue. Thankfully it has now been resolved with an update.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.