Upgrade to 26.0.2 fails 'requires at least PHP 8.0' - I am on 8.0.28

Nextcloud was 25.0.4 (PHP 8.0.28) and I successfully upgraded to 25.0.7. Then I ran the web upgrader to 26.0.2 and did ‘php occ upgrade’ from SSH (same way as I had upgraded to 25.0.7) and it came back with this message ‘This version of Nextcloud requires at least PHP 8.0
You are currently running 7.4.33. Please update your PHP version’
I am on PHP 8.0.28 for this site, however the webserver has several PHP versions including PHP 7.4.33.
Here is the PHPINFO:

PHP Version 8.0.28

System Linux web1 5.4.0-150-generic #167-Ubuntu SMP Mon May 15 17:35:05 UTC 2023 x86_64
Build Date Feb 14 2023 18:32:57
Build System Linux
Server API FPM/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php/8.0/fpm
Loaded Configuration File /etc/php/8.0/fpm/php.ini
Scan this dir for additional .ini files /etc/php/8.0/fpm/conf.d
Additional .ini files parsed /etc/php/8.0/fpm/conf.d/10-mysqlnd.ini, /etc/php/8.0/fpm/conf.d/10-opcache.ini, /etc/php/8.0/fpm/conf.d/10-pdo.ini, /etc/php/8.0/fpm/conf.d/15-xml.ini, /etc/php/8.0/fpm/conf.d/20-apcu.ini, /etc/php/8.0/fpm/conf.d/20-bcmath.ini, /etc/php/8.0/fpm/conf.d/20-calendar.ini, /etc/php/8.0/fpm/conf.d/20-ctype.ini, /etc/php/8.0/fpm/conf.d/20-curl.ini, /etc/php/8.0/fpm/conf.d/20-dom.ini, /etc/php/8.0/fpm/conf.d/20-exif.ini, /etc/php/8.0/fpm/conf.d/20-ffi.ini, /etc/php/8.0/fpm/conf.d/20-fileinfo.ini, /etc/php/8.0/fpm/conf.d/20-ftp.ini, /etc/php/8.0/fpm/conf.d/20-gd.ini, /etc/php/8.0/fpm/conf.d/20-gettext.ini, /etc/php/8.0/fpm/conf.d/20-gmp.ini, /etc/php/8.0/fpm/conf.d/20-iconv.ini, /etc/php/8.0/fpm/conf.d/20-igbinary.ini, /etc/php/8.0/fpm/conf.d/20-imagick.ini, /etc/php/8.0/fpm/conf.d/20-imap.ini, /etc/php/8.0/fpm/conf.d/20-intl.ini, /etc/php/8.0/fpm/conf.d/20-ldap.ini, /etc/php/8.0/fpm/conf.d/20-mbstring.ini, /etc/php/8.0/fpm/conf.d/20-mysqli.ini, /etc/php/8.0/fpm/conf.d/20-oauth.ini, /etc/php/8.0/fpm/conf.d/20-pdo_mysql.ini, /etc/php/8.0/fpm/conf.d/20-pdo_sqlite.ini, /etc/php/8.0/fpm/conf.d/20-phar.ini, /etc/php/8.0/fpm/conf.d/20-posix.ini, /etc/php/8.0/fpm/conf.d/20-pspell.ini, /etc/php/8.0/fpm/conf.d/20-readline.ini, /etc/php/8.0/fpm/conf.d/20-redis.ini, /etc/php/8.0/fpm/conf.d/20-shmop.ini, /etc/php/8.0/fpm/conf.d/20-simplexml.ini, /etc/php/8.0/fpm/conf.d/20-smbclient.ini, /etc/php/8.0/fpm/conf.d/20-soap.ini, /etc/php/8.0/fpm/conf.d/20-sockets.ini, /etc/php/8.0/fpm/conf.d/20-sqlite3.ini, /etc/php/8.0/fpm/conf.d/20-sysvmsg.ini, /etc/php/8.0/fpm/conf.d/20-sysvsem.ini, /etc/php/8.0/fpm/conf.d/20-sysvshm.ini, /etc/php/8.0/fpm/conf.d/20-tidy.ini, /etc/php/8.0/fpm/conf.d/20-tokenizer.ini, /etc/php/8.0/fpm/conf.d/20-xmlreader.ini, /etc/php/8.0/fpm/conf.d/20-xmlrpc.ini, /etc/php/8.0/fpm/conf.d/20-xmlwriter.ini, /etc/php/8.0/fpm/conf.d/20-xsl.ini, /etc/php/8.0/fpm/conf.d/20-zip.ini
PHP API 20200930
PHP Extension 20200930
Zend Extension 420200930
Zend Extension Build API420200930,NTS
PHP Extension Build API20200930,NTS
Debug Build no
Thread Safety disabled
Zend Signal Handling enabled
Zend Memory Manager enabled
Zend Multibyte Support provided by mbstring
IPv6 Support enabled
DTrace Support available, disabled
Registered PHP Streams https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar, smb, zip
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2, tlsv1.3
Registered Stream Filters zlib., string.rot13, string.toupper, string.tolower, convert., consumed, dechunk, convert.iconv.*

Any help greatly appreciated as I am stuck in Maintenance Mode at the moment!

Upgrade your CLI PHP as well to match your web server PHP.

The occ command isn’t relying on your PHP FPM installation so it’s using your CLI version (which is apparently v7.4.33 on your server).

You’ll want to always keep your web-app server and CLI PHP versions matched up for occ to function in the same way as the web app.

Thanks, that was the issue. I was able to continue with web-based updater after generating a new secret and placing it in the config file. I will work on the CLI PHP