Upgrade to 21.0.1 fails on step 5, verifying integrity

Nextcloud version : 20.0.8
Operating system and version (eg, Ubuntu 20.04): Linux 5.4.80-combell x86_64 (shared hosting)
PHP version (eg, 7.4): 7.3.27

I ran the updater, and it fails on step 5, verifying integrity.
More details returns nothing.

The output of the updater.log

2021-04-11T11:55:46+0200 weIVL3rFZJ [info] POST request for step "5"
2021-04-11T11:55:46+0200 weIVL3rFZJ [info] startStep("5")
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] verifyIntegrity()
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] getUpdateServerResponse()
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] updaterServer: https://updates.nextcloud.com/updater_server/
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] releaseChannel: stable
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] internal version:
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] updateURL: https://updates.nextcloud.com/updater_server/?version=20x0x8x1xxxstablexx2021-02-24T19%3A11%3A39%2B00%3A00+1ff83111a63e795079d668bb15ffa84c1024596dx7x3x27
2021-04-11T11:55:47+0200 weIVL3rFZJ [info] getUpdateServerResponse response: Array
    [version] =>
    [versionstring] => Nextcloud 21.0.1
    [url] => https://download.nextcloud.com/server/releases/nextcloud-21.0.1.zip
    [web] => https://docs.nextcloud.com/server/21/admin_manual/maintenance/upgrade.html
    [changes] => https://updates.nextcloud.com/changelog_server/?version=21.0.1
    [autoupdater] => 1
    [eol] => 0
    [signature] => YJQMb8iq13NhbvfEddaSjNeqlMe/dB0nJ27EwmiAuqSMMRpvVg4BjijfNjoG8lY9

2021-04-11T11:55:47+0200 weIVL3rFZJ [info] storage location: /data/sites/web/servername/data/nextcloud/updater-ocuo3ftxsfn1/downloads/

I tried it twice now, by removing the updater folder in data.
Any ideas?

Apparently when I tried to upgrade again, it now tried to upgrade to 20.0.9, but the result was the same.

I now manually upgraded by copying the files to my web host and run the updater when accessing the application. This worked.

Is it possible this is caused by low memory on the hosting machine?
If verifying the package means reading the archive file in memory (around 150MB) that could very well be the issue, as my shared hosting package is below the recommended 512MB.

1 Like

I got the same problem as your’s. Trying to update to 20.0.9 on raspberry with php 7.3.27.
Increasing the php memory from 128MB to 256MB sloved that issue for me.
So thanks for your hit with the memory, maybe you’re able to increase your memory as well.

1 Like