Upgrade to 12.01 failed, stuck in step 4

I am running Nextcloud on a shared hosting account at Dreamhost with php 7.0. It’s slow but it works fine for what I need it for. I tried to update to 12.0.1 but I got an error message during step 4 the backup. I was stupid enough not to copy it. I waited for another 30 minutes and when still nothing happened I changed ‘maintenance’ to false in the config.php. I can now log in again and and in the admin I see again that 12.0.1 is available, but when I click on [Open updater] I get “Step 4 is currently in process. Please reload this page later.”

I think no changes have been made to my system and I would like to start again from the beginning (so I can copy the error this time :roll_eyes:), but don’t know what to do now. Any suggestions? I am a beginner when it comes to Linux, but I am not afraid to poke around. I had to start once from scratch and that’s OK too.

Is the error “Parsing response failed.” ?
I possibly have the same (see below), and those users too:

Myself installed Nextcloud july 12 at shared hosting Binero.se by using the install script. PHP 7.0, MySQL. Strangely it installed NC 11 despite 12 had been out a while. Directly after install and configuration it suggested upgrade to 12 which then performed OK except the theming bug scan.nextcloud.com causing exception in theming? · Issue #4987 · nextcloud/server · GitHub.

A couple days ago i noticed it offered update to 12.0.1, and i let it update. First it complained about my tools.php file from ownCloud Central, so i removed it, and retried. Then after many minutes at step 4 (Create Backup) i got the error: “Parsing response failed.”

I retried it the day after, and got the same.

Here is relevant part of updater.log:

2017-08-09T20:41:22+0200 lxM8RdppZ9 [info] endStep(“3”)
2017-08-09T20:41:22+0200 k7fMHZin2s [info] request to updater
2017-08-09T20:41:22+0200 k7fMHZin2s [info] currentStep()
2017-08-09T20:41:22+0200 k7fMHZin2s [info] Step 3 is in state “end”.
2017-08-09T20:41:22+0200 k7fMHZin2s [info] POST request for step “4”
2017-08-09T20:41:22+0200 k7fMHZin2s [info] startStep(“4”)
2017-08-09T20:41:22+0200 k7fMHZin2s [info] createBackup()
2017-08-09T20:47:42+0200 k7fMHZin2s [info] end of createBackup()
2017-08-09T20:47:42+0200 k7fMHZin2s [info] endStep(“4”)
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] request to updater
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] currentStep()
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] Step 4 is in state “end”.
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] POST request for step “4”
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] startStep(“4”)
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] createBackup()
2017-08-09T20:52:31+0200 YrNmQdzOPF [info] backup folder location exists
2017-08-09T20:58:24+0200 YrNmQdzOPF [info] end of createBackup()
2017-08-09T20:58:24+0200 YrNmQdzOPF [info] endStep(“4”)
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] request to updater
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] currentStep()
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] Step 4 is in state “end”.
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] POST request for step “4”
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] startStep(“4”)
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] createBackup()
2017-08-09T21:23:27+0200 pF6PrtMxfw [info] backup folder location exists
2017-08-09T21:29:43+0200 pF6PrtMxfw [info] end of createBackup()
2017-08-09T21:29:43+0200 pF6PrtMxfw [info] endStep(“4”)

It seem to always retry step 4 and then realise that folder already exists.

  • IMO - it should report that on the user interface!

But i guess that is a secondary error, and the primary problem is is that “Parsing response failed.” Unfortunately that message dont tell us much: What is what trying to do when getting parsing error on what response from what??

For me, it complained about a folder called .well-known, which I removed. I can’t recall exactly what the error was, but it could not complete the backup and something about error 500. My system won’t start over as it “sees” it is already in the middle of an upgrade. I would like to remove the traces of the update it is currently in, so I can try again, from the beginning.

In Nextcloud_folder/config/config.php I changed the line
’maintenance’ => true,
’maintenance’ => false,

I did not touch the ‘updater.secret’ => mombojumbo line, and nexcloud operates. When i now start the updater it continues with the step after “Create backup”…

…and all suceeds.

Unfortunately, after 24h I still get “Step 4 is currently in process. Please reload this page later.” when I click on [Open Updater]. I am pretty sure it is not doing the backup.

Anyone has a suggestion how I can re-initialize the update process so I can start from the beginning?

Anyone? I can see the 12.0.2 update now, but when I click on open updater, I immediately see “Step 4 is currently in process. Please reload this page later.”

Is there another way to update? Any help is greatly appreciated.

try this: Step 7 is currently in process. Please reload this page later

Thanks, but I get a “Username is not in the sudoers file. This incident will be reported.” I am with Dreamhost on a shared hosting plan and they won’t allow me to changes this file.

Can you use the terminal? With some luck you are already using the same user who is also running the php scripts. So you can try to run it without sudo in front (just php occ ...).

Yes I can use the terminal, but this is where things get weird. :wink:
The shell command fails as it claims PHP it too old (5.5.38):

[server]$ php -v
PHP 5.5.38 (cli) (built: Aug  3 2016 20:49:47)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
[server]$ php occ upgrade
This version of Nextcloud requires at least PHP 5.6.0
You are currently running 5.5.38. Please update your PHP version.

However, in Nextcloud on https://myserver/index.php/settings/admin/serverinfo I see this:

Version: 7.0.21

This might also be the cause the update failed in the first place. I will check with Dreamhost what the problem is.

Have you tried this command?

php occ maintenance:repair

I hesitate to revive this but I hit this same error, used a search engine to find answers and found this question and not the question that has the answer that has worked for me (a shared hosting user) in the past. So I’m chiming in to say that if you’re on shared hosting and hitting this error, you might find this question helpful: