Upgrade process from 17 to 18.0.10 fails with error (web-installer)

Dear community,
when trying to upgrade my nextcloud installation (web installer) the process got stuck with an error.
I already searched this community for similar problems but did not find issues with the same error message.
Do you have any idea howto solve this issue?

Error-Message (detailed):
Aktualisierung auf 18.0.10

InvalidArgumentException: Column name “DoTlW_flow_operations”.“entity” is NotNull, but has empty string or null as default.
Detaillierte Protokollmeldungen

Update vorbereiten

Log-Level auf “debug” gesetzt

Wartungsmodus eingeschaltet

Reparaturschritt: Repair MySQL collation

Reparaturinformation: All tables already have the correct collation -> nothing to do

Reparaturschritt: Repair SQLite autoincrement

Reparaturschritt: Copy data from accounts table when migrating from ownCloud

Reparaturschritt: Drop account terms table when migrating from ownCloud

Das Datenbankschema wird aktualisiert

Datenbank aktualisiert

InvalidArgumentException: Column name “DoTlW_flow_operations”.“entity” is NotNull, but has empty string or null as default.

Das Update ist fehlgeschlagen. Bitte melde dieses Problem an die Nextcloud Community.`

I think you should try to improve your searching skills, because it took me less than 5 seconds to find the following posting. Many more exists on the forum, you only have to use the search function to find it. To increase the number of matches you should use the default database table prefix “oc_” instead of “DoTIW_” :wink:

1 Like

Thanks a lot, @j-ed! Problem solved
You are right. I have to improve my searching skills :slight_smile:

My learning: default database table prefix is “oc_”. I will consider this when I search the next time. Searching for “oc_flow_operations”.“entity” is NotNull returns relevant postings.

Solution summary (copied from https://github.com/nextcloud/server/issues/23174):

The error message implies that there is an issue with the default of column entity in table oc_flow_operations (replace “oc_” with your individual prefix). It turns out the column entity was missing from the table entirely. Hence, I just added the column to the table. The following steps solved the issue (in my case I replaced “oc_flow_operations” with “DoTlW_flow_operations”):

  1. Connect to the nextcloud database:
  2. Check if the column is available:
    SELECT entity FROM oc_flow_operations;
    If this command returns
    ERROR: column "entity" does not exist
  3. Add the column to the table
    ALTER TABLE oc_flow_operations (in my case: )
  4. Run the Update on the nextcloud webpage.
1 Like