Upgrade from php5 to php7 done ... but opcache

OK,

I use php 7:
php -v
PHP 7.0.27-0+deb9u1 (cli) (built: Jan 5 2018 13:51:52) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache v7.0.27-0+deb9u1, Copyright © 1999-2017, by Zend Technologies
and apache 2.4.25:
apache2 -v
Server version: Apache/2.4.25 (Debian)
and nextcloud 13.0.1
on a debian 9 …

in a first time when i just upgrade from php5 to php7 , i gest an “internal error” …

so i juste remove " ‘memcache.local’ => ‘\OC\Memcache\APCu’," from my /var/www/html/nextcloud/config/config.php …
and the “internal server error” has gone :slight_smile:

but now, i have to fixe this, so i juste make an “apt-get install php-apcu” and if i add " ‘memcache.local’ => ‘\OC\Memcache\APCu’," , i get an internal server error again :frowning:

my second problem is php opcache, i uncomment and set variables has it say in parameter:

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

in my /etc/php/7.0/apache2/php.ini
after that i do a: phpenmod opcache and a systemctl restart apache2

and …nothing change i still have a notice when i log in nextcloud in “parameters” menu

so if you can help me … big thx !

according to phpinfo(), it seems than my php.ini is:
Loaded Configuration File /etc/php/7.0/fpm/php.ini

so i make all change in this files but i still have notice in the nextcloud parameters menu…

now, i just discover that i must do a /etc/init.d/php7.0-fpm restart …

and you know what … ? : all notice about opcache in paramaters menu has disapear :slight_smile:

so now i juste have to find why ‘memcache.local’ => ‘\OC\Memcache\APCu’ in the config.ini file cause my “internal server error”

may i have to create another post just for that ?

ok,

instead of copy/paste the " ‘memcache.local’ => ‘\OC\Memcache\APCu’" i xrite it directly in the config.php file … works’s fine now …