Upgrade from 26.0.5 to 27.0.2 resulted in Broken UI, but only for pubdomain

Hi community,

Nextcloud version (eg, 20.0.5): 27.0.2
Operating system and version (eg, Ubuntu 20.04): Debian 11
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.56
PHP version (eg, 7.4): php 8.1.22

The issue you are facing:

We updated from 24.0.1 to 25.0.10, then 26.0.5 and finally to 27.0.2. With v.26 we Upgraded PHP to 8.1.22, which is active now. With the last step, the UI went somehow broken when using the external DNS, using the internal hostname, everything is fine. I only see the blue background, but the Loginmask does not appear. We did not change anything on the Apache Webserver, nor on the Reverseproxy in Front. I also tried adapting the hosts file of my local machine an pointing to the NC Instance directly (without using the Reversproxy in front) but the problem stays the same.

Was anything changed in v27 in regards to webfrontend/TLS/SNI behaviour? Do I have to adapt something for v27?

I will also attach a screenshot of the issue, you can have a look, how it looks like.

Steps to replicate it:
Simply open the nextcloud.mypubdomain.com, the issues persists all the time.

My config PHP contains this since the initial installation:

‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => ‘nc.mypubdomain.com’,
2 => ‘nextcloud.mylocaldomain.local’,
),
‘trusted_proxies’ =>
array (
0 => ‘{IP-OF-Reverseproxy}’,
),

Edit: Below I attached the Apache Config:

<VirtualHost nextcloud.mylocaldomain.local:80>
ServerName  nextcloud.mylocaldomain.local
ServerAlias nextcloud.mylocaldomain.local

Redirect permanent / https://nextcloud.mylocaldomain.local/

</VirtualHost>

<VirtualHost nextcloud.mylocaldomain.local:443>
DocumentRoot /srv/www/nextcloud/
ServerName  nextcloud.mylocaldomain.local
ServerAlias nextcloud.mylocaldomain.local nc.mypubdomain.com

<IfModule mod_headers.c>
      Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
    </IfModule>

SSLEngine On
SSLProxyEngine On
SSLCertificateFile /etc/apache2/ssl/123.cer
SSLCaCertificateFile /etc/apache2/ssl/123_intermediate.cer
SSLCertificateKeyFile /etc/apache2/ssl/private/priv.key

  <Directory /srv/www/nextcloud/>
    Require all granted
    AllowOverride All
    Options FollowSymLinks MultiViews

    <IfModule mod_dav.c>
      Dav off
    </IfModule>
  </Directory>
CustomLog ${APACHE_LOG_DIR}/nextcloud.log combined
Loglevel debug
</VirtualHost>

Thanks!

Update:

I double checked with the public name, and this is also working, when pointing directly to the webserver. The Reverseproxy in Front somehow causes the issue after the update to v27.

How can I debug the issue? Are there additional settings, that can help here?

Anybody?

I´m running out of ideas. I will propably downgrade the system to v.26 again.

Same bug for me. After checking and changing Router-Settings for that server i could get the pubdomain to work again, lol.