Upgrade from 19.0.6 to 20.0.4 crashed, how to restore 19.0.6?


I have updated from 19.0.5 to 19.0.6 and then I tried to upgrade to 20.0.4 but it has crashed.

I didn’t see any error message in the logs displayed in the upgrade process web page neither in data/updater.log.

The instance is now stucked in the maintenance mode and I don’t know what to do. Since I start to use NC 1.5 year ago it’s the first time I have an issue during the upgrade process.

The output of “occ status” is:

Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
  - installed: true
  - version:
  - versionstring: 20.0.4
  - edition: 

But in config.php the version is still

In fact I’d like to restore the 19.0.6 because there are apparently some issues with NC 20 and my favorite apps (tasks and calendar).

I can see some backup in data/updater-ocmcbuokwldq/backups/nextcloud-

What should I do in order to go back smoothly to 19.0.6 ?

Thanks for your help,


I have had the same problem.
My NC instance is running in a virtual machine so i could restore the complete state of the instance.
Well, but I’m not able to update to 20.0.4

If anyone has a solution, that would be very helpful.
I’m unter Debian.

Thanks for help,

I am also on Debian (stable) but it certainly has nothing to do with the upgrade crash.

I would also be grateful if I had the right method to be able to continue with the upgrade. But in my case the best would be to be able to revert to version 19.0.6. The NC 19.0.6 files were apparently well saved, and I hope that it is the same for the database (this is what is displayed during the preparation phase of the upgrade) but I do not know not where.

Well i think i got it all wrong :frowning:

The built-in updater does not backup the database, it backups only the existing code base. And off course my last db update is almost 3 months old, shame on me.

Now I made a backup but without knowing if the update process has already modified the database. If I could be sure that this is not the case I could then go back to 19.0.6 simply by copying the backup files…

But as occ status indicates that I am in 20.0.4 (and it is 19.0.6 in config.php) this should unfortunately not be the case, there must be a value in db storing the version, right ?

So I’m wondering if the best approach would be to try to manually finish the update to 20.0.4 (and then wait for calendar and task apps to work with NC 20).

Finally I try to finish manually the upgrade just by launching “occ upgrade -v” and it worked without error :slight_smile:

The other good news is that task application seems to work fine with NC20 (as well notes and contacts), so the only app I miss is calendar.