Upgrade from 13.0.0 to 13.0.1

After I apparently updated correctly the Nextcloud version from 13.0.0. to 13.0.1, when I access via web, the update page appears, and when I press Start Update button, it takes about 5 seconds, and appears a mesage saying that has been updated correctly, and that is going to be redirected to my page, but the update page appears and appears again and again.

I have tried to update via web and through the following command (sudo -u www-data php ./occ upgrade) but the result is always the same, the update page appears.

Can someone help me ?

I’ve never had the web updater wok either as it always times out. To do the upgrade manually you want to use the updater.phar not the occ upgrade

cd /var/www/nextcloud

sudo -u www-data php updater/updater.phar

Then you will see the output

Nextcloud Updater - version: v13.0.0beta1

Current version is 13.0.0.

Update to Nextcloud 13.0.1 available. (channel: "stable")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-13.0.1.zip

Steps that will be executed:
[ ] Check for expected files
[ ] Check for write permissions
[ ] Enable maintenance mode
[ ] Create backup
[ ] Downloading
[ ] Verify integrity
[ ] Extracting
[ ] Replace entry points
[ ] Delete old files
[ ] Move new files in place
[ ] Done

Start update? [y/N] y

After it finishes it will then ask to do the occ upgrade

Should the "occ upgrade" command be executed? [Y/n] y

I did the update manually with the command

cd / var / www / nextcloud

sudo -u www-data php updater / updater.phar

and all went well, but the problem is that I am in a loop with the homepage that shows me always I have to perform the update.

I think the update is well done but there is nothing to update.

I do not know if there is any way to tell Nextcloud that the current version is the latest version, and thus prevent the update screen from appearing.

Did you also run the command
sudo -u www-data php occ upgrade?

Give it a try… :wink:

Yes, I already executed the command, but without results. The update screen always appears.

Thank you marvicz for your help anyway.

I attach the contents of the “version.php” file

Have you tried another browser or flushed FF’s cache? If the occ command exited without any issue, you might also want to restart your web server and see, if this cleans things up.

I restarted the web server, and I have tried several browsers, but without results. But the problem may be the cache. I renamed the data folder, and then the update process makes more checks, and at the end the message “Unable to clear the frontend cache” appears, and when the “Continue to Nextcloud” button is pressed, the Update screen appears again.

In “config.php” file, I added this line

‘memcache,local’ => ‘\OC\Memcache\APCu’,

If I execute the command “sudo -u www-data php occ status”, it indicates that there is an application that needs updating, and that the Nextcloud version is the last one available.

Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the upgrade command to upgrade

  • installed: true
  • version:
  • versionstring: 13.0.1
  • edition: