Upgrade 24.0.8 to 25.0.2 sucessful but does not work: Themes / Logo (theming.Theming.getImage) root cause?

Hi,

I update nextcloud via web interface on my hosted webspace. I already did that for another instance (which worked fine) but while now the “klimag”-update itself was successful it does not work.

Nextcloud version: 25.0.2
Operating system and version: Hosted on a linux system (Host Europe)
Apache or nginx version: Apache, version not known
PHP version: 8.1
MySQL Version 5.7.40-43-log

Apache Log entry when http-requesting (by browser) a nextcloud site on the server:

46.85.95.189 - - [08/Jan/2023:13:04:02 +0100] “GET /klimaag/ HTTP/1.1” 500 504 “-” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Firefox/102.0” “joergs-allerlei.de
So, here no obvious error. Apache’s error log is empty.

The used configuration: config.php:

<?php
$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' =>
  array (
    0 => 'joergs-allerlei.de',
  ),
  'datadirectory' => '/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/data',
  'dbtype' => 'mysql',
  'version' => '24.0.8.2',
  'overwrite.cli.url' => 'https://joergs-allerlei.de/klimaag',
  'overwritehost' => 'joergs-allerlei.de',
  'overwriteprotocol' => 'https',
  'dbname' => 'db10613452-klimaag',
  'dbhost' => 'wp611.webpack.hosteurope.de',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'default_language' => 'de',
  'default_locale' => 'de_DE',
  'default_phone_region' => 'DE',
  'skeletondirectory' => '',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'xxx',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'xxx',
  'mail_smtpsecure' => 'tls',
  'mail_domain' => 'joergs-allerlei.de',
  'mail_smtpauthtype' => 'PLAIN',
  'mail_smtpauth' => 1,
  'mail_smtpport' => '25',
  'mail_smtpname' => 'xxx',
  'mail_smtppassword' => 'xxx',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'logtimezone' => 'Europe/Berlin',
  'updater.secret' => 'xxx',
);

HTML output of calling the a nextcloud page:

<!DOCTYPE html>
<html class="ng-csp" data-placeholder-focus="false" lang="de" data-locale="de_DE" >
	<head
 data-requesttoken="8KUzWM11Tmy4svdIUFn8w7NhRsUtsPL2J3Fak6Px1xA=:kZNKObgYHyHOhZIAJxCfu9o7F/R+yYKjShIVuMCCgVo=">
		<meta charset="utf-8">
		<title>
			Klima AG		</title>
		<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0">
				<meta name="apple-itunes-app" content="app-id=1125420102">
				<meta name="theme-color" content="#62bb46">
		<link rel="icon" href="

So, nextcloud breaks by generating the link to the icon (break after href=")
The installation does not have a dedicated theme but background colors and logo were changed (longer time before the update).

And the corresponding nextcloud.log to it:

{"reqId":"KqKRiI4GZMyBlYzQ56ss","level":1,"time":"2023-01-08T12:23:06+01:00","remoteAddr":"46.85.95.189","user":"--","app":"no app in context","method":"GET","url":"/klimaag/","message":"Unable to generate a URL for the named route \"theming.Theming.getImage\" as such route does not exist.","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Firefox/102.0","version":"24.0.8.2","exception":{"Exception":"Symfony\\Component\\Routing\\Exception\\RouteNotFoundException","Message":"Unable to generate a URL for the named route \"theming.Theming.getImage\" as such route does not exist.","Code":0,"Trace":[{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/Route/Router.php","line":361,"function":"generate","class":"Symfony\\Component\\Routing\\Generator\\UrlGenerator","type":"->","args":["theming.Theming.getImage",["logo",true,"42"],1]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/URLGenerator.php","line":103,"function":"generate","class":"OC\\Route\\Router","type":"->","args":["theming.Theming.getImage",["logo",true,"42"]]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/apps/theming/lib/ThemingDefaults.php","line":304,"function":"linkToRoute","class":"OC\\URLGenerator","type":"->","args":["theming.Theming.getImage",["logo",true,"42"]]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/apps/theming/lib/Capabilities.php","line":90,"function":"getLogo","class":"OCA\\Theming\\ThemingDefaults","type":"->","args":[]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/CapabilitiesManager.php","line":75,"function":"getCapabilities","class":"OCA\\Theming\\Capabilities","type":"->","args":[]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/Template/JSConfigHelper.php","line":166,"function":"getCapabilities","class":"OC\\CapabilitiesManager","type":"->","args":[false,true]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/TemplateLayout.php","line":229,"function":"getConfig","class":"OC\\Template\\JSConfigHelper","type":"->","args":[]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/legacy/OC_Template.php","line":184,"function":"__construct","class":"OC\\TemplateLayout","type":"->","args":["guest",""]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/private/Template/Base.php","line":132,"function":"fetchPage","class":"OC_Template","type":"->","args":[]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/base.php","line":414,"function":"printPage","class":"OC\\Template\\Base","type":"->","args":[]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/lib/base.php","line":997,"function":"printUpgradePage","class":"OC","type":"::","args":[{"__class__":"OC\\SystemConfig"}]},{"file":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/index.php","line":36,"function":"handleRequest","class":"OC","type":"::","args":[]}],"File":"/is/htdocs/wp10613452_6DDDY013U1/www/klimaag/3rdparty/symfony/routing/Generator/UrlGenerator.php","Line":143,"message":"Unable to generate a URL for the named route \"theming.Theming.getImage\" as such route does not exist.","exception":{},"CustomMessage":"Unable to generate a URL for the named route \"theming.Theming.getImage\" as such route does not exist."}}
{"reqId":"KqKRiI4GZMyBlYzQ56ss","level":3,"time":"2023-01-08T12:23:07+01:00","remoteAddr":"46.85.95.189","user":"--","app":"PHP","method":"GET","url":"/klimaag/","message":"Declaration of OCA\\Talk\\Share\\RoomShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares): array must be compatible with OCP\\Share\\IShareProvider::getSharesInFolder($userId, OCP\\Files\\Folder $node, $reshares, $shallow = true) at /is/htdocs/wp10613452_6DDDY013U1/www/klimaag/apps/spreed/lib/Share/RoomShareProvider.php#520","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Firefox/102.0","version":"24.0.8.2","data":{"app":"PHP"}}

I would appreciate any help/hints to solve the issue. Thanks in advance!

BR Jörg

Hi,
is there information missing which I can provide for this case?
Jörg

It is a known big currently. You can try to re-apply the theming assets manually…

Hi, thanks a lot! How can I apply those theming assets manually? My instance does not work at all, so interaction via NC user interface is not possible.
BtW: Is it this bug? [Bug]: Logo not showing in header after the update (FIX) · Issue #35871 · nextcloud/server · GitHub → I tried the manual workaround but there already was a logoheader file existing (same file size as logo).

Go into the themin admin settings an re-apply the assets?

Does not work since NC is not usable at all. If I go to …/settings/admin I just received an 404-error.
At the end, I downgraded back to version 24 with restoring backups from database as well as the data folder.