Upgrade 11 to 11.01 stuck

I’m having trouble with my install. I was using the updater app and my site seems to be in a weird state that it can’t get out of. I’ll try and outline the problems:

  • I ran the updater, fixing a few permission errors & then re-ran
  • The updater got to the ‘downloading’ section and then failed with a server 500 error. (That’s what the error message returned. I don’t know if it was my server or some other remote download server). I had a look at my error logs and see these to lines:

[Fri Jan 20 20:36:20.095430 2017] [fcgid:warn] [pid 4765] [client] mod_fcgid: read data timeout in 31 seconds
[Fri Jan 20 20:36:20.095612 2017] [core:error] [pid 4765] [client] End of script output before headers: index.php

The error message also indicated to ‘retry’ later. So I hit refresh…and then ended up at the maintenance mode screen & could not get back to the updater.

  • So, I went to the commandline and disabled maintenance mode.
  • I could log in again, however when I try and click on “Open Updater” button from the admin section, it returns with a blank text page (ie no html), saying:

Step 5 is currently in process. Please reload this page later.

So, being a n00b at this (this is my first update)… I’m pretty thoroughly lost.

Any help would be greatly appreciated!

My system is roughly:

  • Ubuntu 16
  • Virtualmin, so, apache and php7.

I found updater/updater.phar and ran it from the cli (as the proper user): php updater.phar -vvv
and got this response:

Nextcloud Updater - version: 1.0.3
Step 5 is currently in process. Please call this command later.

Moved to support channel

bump…? Any ideas?

If you have command line access, you can use the occ command directly:

sudo -u www-data php /path/to/nextcloud/occ upgrade

Your problem is that the execution time exceeded the default settings and the update script was interrupted. If you run the upgrade command via terminal, you won’t have the problem with time outs. You perhaps need to disable the maintenance mode before running the upgrade command.

I had the same problem. The script starts the download but times out before the download is finished. The download continues in the background, so the file gets downloaded completely. However on clicking retry the script doesn’t recognize the downloaded file but starts the whole process again.

Solution that worked for me:
Exit the website. Turn maintenance mode off. Delete the files that the updater created:
/path/to/nextcloud/data/updater-oc5112dbc0ci (I guess the number at the end could be different)
/path/to/nextcloud/data/appdata-oc5112dbc0ci (should be the same number)

Then run the updater manually:

sudo -u www-data php /path/to/nextcloud/updater/updater.phar


I have the same problem now, but there’re nothing in my data directory.

Hi @BeastTL ,

Please open a new thread and provide server information and logs. I recommend to use the app “issue template”, as it helps you collect the most relevant data and automatically removes confidential data from the config.
I’m closing this one here as solved.