Upgrade 10.? to 11.0.0 seriously flawed

I’ve just upgraded from 10.? to current 11.0.0 running nginx on Ubuntu 16.4. I followed the upgrade instructions given at https://docs.nextcloud.com/server/11/admin_manual/maintenance/upgrade.html starting from a downloaded archive of 11.0.0. The process did not show any irregularities.

The 10.? instance used to work for several months without any problem. After the upgrade I’m facing:

  1. Thunderbird/Lightning calendar sync error messages:
    *** new sync: 25 25/sync with https://xtraservice.de/owncloud/remote.php/carddav/addressbooks/goik/contacts/... GOT STATUS: 404 Unacceptable status code: 404. We abort.

  2. Downloading of files using Web access i.e. clicking on a file’s “three dots” choosing “download” from the dropdown list CONSISTENTLY yields:

     Service Unavailable
     Technical details
     Remote Address:
     Request ID: r84NUX9SRHTXjlPFakoJ
  3. Not surprising the android client fails as well when trying to sync files and issues an error message.

There are however no corresponding records in Nginx’s access.log / error.log files. tail -f … just reveals nothing at all. Do I have to configure additional logging in nextcloud? Hoping for help!

And you nextcloud.log (/path/to/nextcloud/data/nextcloud.log)?

Old DAV URL was removed, simply switch the the current one

Unsubscribing from all calendars in Lightning and re-subscribing using the URLs shown in the nextcloud 11 instances WEB interface worked. Is this what you meant?

Just for curiosity: We are running a different nextcloud instance populated with ~1200 users. Some of them are (uuuhm, how to say?) not too inclined/used configuring software. Do we have to ask them stepping through the same procedure or is there a more convenient way migrating client preferences?

Shame on me!!! I’m running a second nextcloud instance having a “data” directory distinct from /var/www/cloud/html/owncloud. But I updated my first instance and falsely assumed a separated data directory as well. Copying the culprit solved the problem. Sorry for wasting your time!