Upgrade 10.0.1-> 10.0.2 Details->Versions->Thumbnail not found: "SVG mimetype cannot be rendered"

I run ubuntu 16.04 latest 64bit and today I upgraded to 10.0.2 (had to use the cli, app didn’t work with error “Update needed. Please use the command line updater because you have a big instance.”

With the cli the upgrade worked out fine, but with 10.0.2 the icons/thumbnails of some file types (e.g. doc, pptx, …) don’t work any more (see screenshot). Other previews (e.g. txt) work fine.

the nextcloud.log reads:
{“reqId”:“EXXXXXXXXXXXeZjD9p7b”,“remoteAddr”:“XX.XX.XX.30”,“app”:“core”,“message”:“SVG mimetype cannot be rendered”,“level”:0,“time”:“2016-12-13T07:15:29+00:00”,“method”:“GET”,“url”:"/index.php/apps/files_versions/preview?file=%2FXXdocs%2Ffriday_1484.odp&version=1449823183",“user”:“XXXXX”,“version”:“9.1.2.2”}

trying to access svg files with the www-data user succeeds:
-rw-r----- 1 root www-data 595 Dec 12 16:53 /var/www/nextcloud/core/img/filetypes/x-office-presentation.svg

I re-applied the strong permissions script after upgrading, so I don’t think permissions should be the issue?
If 10.0.2 makes a real preview of some office documents, I might miss the render engine (libreoffice is not installed on the server).

I didn’t see this problem before with 10.0.1
Also, I use redis for transactional locking and apcu for local caching (set up according to the nextcloud howtos)

Tim

screenshot:

1 Like

I have a similar issues to that of @chaos_prevails.
While looking for an older version of one of my text files, I also found that thumbnails for older versions were missing.
In Firefox, inspecting the element gives me a “Could not load the image” tooltip while looking at the Inspector pane.
Looking at the Network pane it says error 500 for the thumbnails.
In the logs don’t read anything related to this issue.