Updating Nextcloud to V 16.0.9 - Verifying integrity Signature of update is not valid

Hi There
I am trying to update my encrypted Nextcloud 16.0.7. to version 16.0.9. The problem is that the updater always stucks on “Verifying integrity, Signature of update is not valid”. I tried more than 3 times after deleting the step file.

I am running on PHP 7.3.15
My Server: Plesk on Ubuntu 16.04

Until now every update was running without problems. I am having also other installations on my server which are already upgraded to Nextcloud 18 withouth problems.

Any advice how to fix this issue? Looking forward to get some tips!

Same problem here :frowning:
Looks like: Updating error on verifying integrity
Link to download seems to point to 16.0.0.zip instead of 16.0.9.zip which I guess causes the integrity check to fail. Other updates to 18 did work because (my guess) 16.0.9 didn’t exist and the link for the previous versions were ok …

1 Like

Solved by uploading the 16.0.9 zip file manually via SFTP.

when stucks on “Verifying integrity, Signature of update is not valid”.
1.download https://download.nextcloud.com/server/releases/nextcloud-16.0.9.zip
2.rename filename to nextcloud-16.0.0.zip
3.upload to the updater path and replace the updater auto download zip file
4.click [retry update]

1 Like

ok!! it worked. tnx :smiley:

1 Like

i’m having the same issue.
But it doesn’t work with my server.
I downloaded https://download.nextcloud.com/server/releases/nextcloud-16.0.9.zip renamed to nextcloud-16.0.0.zip and uploaded to the nextcloud directory:

When i click retry it shows the same error. Is the above updater folder the right place to put it?

1 Like

I’ve done the same downloaded 16.0.9 I uploaded that one and also uploaded a renamed one and even the original 16.0.0 so I tried 3 versions but … nothing … still stucks on “Verifying integrity, Signature of update is not valid”.

Confirmed that downloading 16.0.9.zip to replace the updater downloaded 16.0.0.zip worked, just click Retry Update after replacing the file!

Would be nice to hear why this happened though…

1 Like

@usrjph: could you please tell to which folder you uploaded the renamed zip file?

The updater files are in your data directory, so for me it looked like:


Just replace that file with the corrected zip, but with the same 16.0.0.zip name so the updater app picks it up!

1 Like

Fix is in the queue: https://github.com/nextcloud/server/issues/19928


I accidently copied it directly in the updater folder…
Thanks @usrjph now the update runs.