Updating NC 11.0.2 to 11.0.3 fails at Extracting (zip error code 5)

I tried using the web updater and it failed to update from .2 to .3 (it worked fine from .0 and from .1 to .2 before).

Nextcloud version (eg, 10.0.2): 11.0.2
Operating system and version (eg, Ubuntu 16.04): ARMbian 5.25 stable Debian 8 (jessie)
Apache or nginx version (eg, Apache 2.4.25): Nginx 1.6.2-5
PHP version (eg, 5.6): 5.6.30
Is this the first time you’ve seen this error?: yes, but it persits

Can you reliably replicate it? (If so, please outline steps):

  1. I set the right permissions
  2. start the web updater
  3. fail at Extracting with the following error:

Cant handle ZIP file. Error code is: 5

I retried a few times, but still the same issue.

The output of your Nextcloud log in Admin > Logging (the time-wise relevant ones):

Error	core	ImageMagick says: Failed to read the file	2017-05-05T10:33:00+0200
Error	PHP	Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. at Unknown#0

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

I can pastebin that somewhere if needed. (BTW, wasn’t there a tool to anonymise your config.php? If so, shouldn’t it be mentioned in the support template?)

The output of your Apache/nginx/system log in /var/log/____:

2017/05/05 10:10:42 [error] 8854#0: *50584 upstream timed out (110: Connection timed out) while reading response header from upstream, client:, server: thatfunkyplace.wheremymonkeyis.at, request: “POST /updater/index.php HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock”, host: “thatfunkyplace.wheremymonkeyis.at

I might be completely wrong, but the timeout error seems quite obvious to me, it just takes too long to extract the zip file. You can try to increase the timeout settings for php (php.ini) and the fastcgi-interface (nginx config).

I’m still used to the buggy owncloud updates which made me use manual updates which is not so hard either (and works):

  • create backup
  • delete all folders except for data/ and config/
  • download and extract code from nextcloud.com/changelog
  • set permissions (easy: sudo chown -R www-data.www-data /var/www/nextcloud/*)
  • run upgrade from terminal (sudo -u www-data php /var/www/nextcloud/occ upgrade)
  • install your apps again.

I’ll probably try the timeout settings first and if that fails, do a manual update. I hope that won’t break the automatic updates later on.

The odd bit is that on the same box it used to work fine before.

Hi there,
Just wondering if this ever got resolved? I’m having the same issue as Hook above, more specifically the

Cant handle ZIP file. Error code is: 5

I’m using a raspberry pi 3, raspian version 8 jessie. php 7.0 Nginx 1.6.2-5.

I’m Attempting to migrate from Owncloud 10 to Nextcloud 12 using the web updater…it’ll run but get hung at this zip error code 5 everytime. (following instructions for https://nextcloud.com/migration/) I have installed zip as well. I’ve googled the hell out of this one and have come up empty.

I’m unclear about what exact file and what lines to edit for timeout settings as tflidd had mentioned in this thread. (thinking he means /etc/php/7.0/cli/php.ini but, unsure of what variables to change, there are like 7 timeout lines)

THANKS in advance for any insight on how to proceed.