Updating Issues (Nextcloud backup directory found. Interrupted installation?)

During the Upgrade of my NextCloudPi instance to Nextcloud version 20.0.3 the update panel suddenly blanked out with an error displaying on the top left. When I refreshed the page and tried to press update again it threw me the error “Nextcloud backup directory found. Interrupted installation?”. When I visited my nextcloud instance a button appeared to migrate the database to Nextcloud 20.0.3. When I did that it got into a loophole that stopped at some point out of nowhere. After that almost all my apps where uninstalled as it seems like the nextcloud folder is corrupt or something. Somewhat later I tried to update via the console again then it told me “Malformed version”.

Somewhat earlier I also saw a folder named nextcloud_old under /var/www/ which got deleted for some reason.

That is basically the point I am at right now and I have no idea how I could fix this without destroying anything. Any help will be appreciated :slight_smile:

That situation should only happen if there’s a power cut or similar.

You should have a backup file on /var/www/ that you can restore with nc-restore

(sudo ncp-config -> BACKUPS -> nc-restore -> enter complete path to /var/www/filename.tar.gz)

1 Like

Thank you for your reply :slight_smile:

Unfortunately, I am not able to find any backup file or folder at all in my /var/www/ folder. I can only find the folders which you can see in the screenshot below.
image

I also did not have any form of a power outage during the updating process as well so I, unfortunately, do not know what could have caused this.

I do not see nextcloud-old either on your screenshot. Maybe the upgrade did go through, but took a while?

1 Like

I saw it when I accessed that folder like 10 or so minutes after the update but I thought the folder doesn’t matter because it had an older date maybe I miss seen that or something. If I do ncp-update-nc now it tells me that I have a malformed version so it seems it did not go through correctly at least.
image

you are not supposed to do ncp-update-nc from the command line, but from sudo ncp-config

1 Like

look at the ncp-web panel, looks like the upgrade went through, it just took a bit

1 Like

Seems like the issue is only happening on that command. On the web panel and ncp-config it’s fine! :slight_smile:
Thank you so much for your help!

Hi, I have a similar problem.

Yesterday, my update from NC 18 to NC 19 failed due to a blackout.

I reinstalled my backup but when trying to update NC via NextCloudPi I get the same error message as @Thorge: “Nextcloud backup directory found. Interrupted installation?”.

I finally updated to NC 19 using the NextCloud-interface. When I now try to update to NC 20 via NCP I still get the same error message. Any idea how I can run updates via NCP again?

You can simply remove the backup dirextory

1 Like

perfect, thank you!