Updates failing because of an expired TLS certifificate


The certificate served by updates.nextcloud.com (https://crt.sh/?id=3014348246) expired about 6 hours ago (Sep 27 02:40:13 2020 GMT) which causes the updater app to fail to connect.
A new certificate, that is currently valid, had been issued on Aug 29th https://crt.sh/?id=3305013326 but it might have not been properly installed or the server hasn’t been reloaded since then to pick it up.


Thanks for the message!
What is the typical behaviour in case of trying an update?
My updater (browser) just tells me “Initializing - Current version is 18.0.9”.
Is that what happens?



Yup, that’s the “symptom” of the issue

OK. Thanks for your work on this phantastic software.


@MorrisJobke @rullzer Are you able to trigger the certificate update on the server?

Can you say how long it will take to update the certificate on updates.nextcloud.com? I just prepared the update of a bigger installation and stuck in this issue. Would need to roll-back my preps, if the issue cannot solved short-term.

Thanks in advance,

Should work again.

1 Like

Works now - perfect! :slight_smile:

Here is a late “Thank you”!