Updated NCPI to Debian Buster, everything seems broken now

SOLVED? See very bottom for edit

Using NCPI 16.03 nextcloud version (latest supported by ncpi).

I followed this to update my sever running Debian 9, to Debian 10: https://linuxconfig.org/how-to-upgrade-debian-9-stretch-to-debian-10-buster

it asked if I wanted to keep the locally modified samba, and I chose to use the repo managed version. This is the only deviation I made as the rest was mainly automated.

I also still have 93 packages held back: https://pastebin.com/TGaSLC1i

Also, when I ssh into my server, upon logging in, it still tells me there is a Debian upgrade available and to run
sudo ncp-dist-upgrade

The main issue is that I can’t connect to the nextcloud instance. I CAN access the ncp-config tools via ssh though. When I try to run

I get:

Running nc-fix-permissions
sudo: php: command not found
data directory not found
Done. Press any key...

My Nextcloud directory and it’s files are still on the home directory though. I also made an rsync backup and a nc-backup (minus data) prior to this.

When I try to access the nextcloud server via web browser, I get a bunch of text on the screen instead of a gui, same for nc-webui access.

I’m not sure what other info to provide, please let me know.

EDIT: I ran ncp-dist-upgrade and This is the entire output: https://pastebin.com/P3VUXxbu everything seems to be working now? Little concerned about the error at the very end:

sed: can't read /etc/mysql/mariadb.conf.d/91-ncp.cnf: No such file or directory
Something went wrong. Fix it and try again

I think this is NextClouPi dist upgrade, not debian upgrade…

Will upgrade OS from Stretch (Debian/Raspbian9) to Buster (Debian/Raspbian10)

You can, but do not have to run ncp-dist-upgrade, you still get security updates for 9 for some time to come.

1 Like