Update von 18.04 auf 18.06 fehlgeschlagen

Hallo,

ich wollte meine Nextcloud von 18.04 auf 18.06 aktualisieren, doch leider terminierte sich der updater. Ein Versuch den update modus zu deaktivieren, indem ich in der config.php den maintenance mode auf false gesetzt habe, blieb ohne Erfolg.
Scheinbar ist bei dem update mehr kaputt gegangen, denn wenn ich den maintenance mode über occ deaktivieren möchte bekomme ich folgende Meldung:

#0 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(115): OC\AppFramework\Utility\SimpleContainer->resolve()
#1 /var/www/nextcloud/lib/private/ServerContainer.php(150): OC\AppFramework\Utility\SimpleContainer->query()
#2 /var/www/nextcloud/lib/base.php(735): OC\ServerContainer->query()
#3 /var/www/nextcloud/lib/base.php(1089): OC::init()
#4 /var/www/nextcloud/console.php(48): require_once(’/var/www/nextcl…’)
#5 /var/www/nextcloud/occ(11): require_once(’/var/www/nextcl…’)
#6 {main}user@cloud:/var/www/nextcloud

Welche Reparaturmöglichkeiten gibt es noch?

Besten dank im voraus

Andreas

Vermutlich eine App die das Update verhindert. Du kannst App für App mit dem occ-Befehl deaktivieren und das Update nochmal versuchen.

ich hab versucht mit ‘sudo -u www-data php occ app:list’ eine Liste der apps zu bekommen, aber
sobald ich occ aufrufe bekomme ich die Fehlermeldung wie s. O.

sry, hab nur den stack trace gesendet. Die Fehlermeldung dazu lautet:

An unhandled exception has been thrown:
OCP\AppFramework\QueryException: Could not resolve OCA\Settings\AppInfo\Application! Class OCA\Settings\AppInfo\Application does not exist in /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php:106

Ok,

Die magische Lösung war ein manueller Upgrade. Gut beschrieben in der Dokumentation.

https://docs.nextcloud.com/server/18/admin_manual/maintenance/manual_upgrade.html

Ein bisschen Schwierigkeiten machte noch das Update vom Community Document Server Version 0.1.6 auf 0.1.7. Das Problem war ein Timeout:

Error: cURL error 28: Operation timed out after 120000 milliseconds with ……

nachdem ich diese in der /var/www/nextcloud/lib/private/Installer.php von 120 auf 300 Sekunden erhöht habe, war auch das letzte Problem beseitigt.

Line 279 $timeout = $this->isCLI ? 0 : 300;