Update to Nextcloud v22 breaks calendar app (column "deleted_at" does not exist)

Nextcloud version (eg, 20.0.5): 21.0.9 → tried updating to 22.2.5
Operating system and version (eg, Ubuntu 20.04): Debian with Linux 5.15 with Nextcloud running inside a Docker container using the linuxserver/nextcloud image.
Apache or nginx version (eg, Apache 2.4.25): nginx 3.14
PHP version (eg, 7.4): 7.4.26

The issue:

While updating from Nextcloud version 21.0.9 to version 22.2.5 the code integrity fails to be verified. Aside from that, the upgrade does finish and all features besides the calendar app work. From what I could gather from the logs, this has to do with a missing column called deleted_at in the database table belonging to the calendar app. No calendar data is lost during the update, but for some reason the deleted_at column does not exist after the update.

Is this the first time you’ve seen this error? (Y/N): N

I’ve done the update process multiple times, each time encountering the same issue and subsequently restoring a backup.

Steps to replicate it:

  1. Update Nextcloud from version 21.0.9 to version 22.2.5 with the calendar app installed

The output of your Nextcloud log in Admin > Logging:


$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.distributed' => '\OC\Memcache\Redis',
  'redis' => [
     'host'     => 'nextcloud-redis',
     'port'     => 6379,
  'memcache.locking' => '\OC\Memcache\Redis',
  'datadirectory' => '/data',
  'instanceid' => 'xxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxx',
  'secret' => 'xxxxxxxxx',
  'trusted_domains' =>
  array (
    0 => 'my_domain.com',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwritehost' => '',
  'overwritewebroot' => '/',
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'app_install_overwrite' =>
  array (
    0 => 'keeweb',
    1 => 'files_external_gdrive',
    2 => 'drop_account',
  'dbuser' => 'nextcloud',
  'dbpassword' => 'xxxxxxxxx',
  'has_rebuilt_cache' => true,
  'trusted_proxies' =>
  array (
    0 => '',
    1 => '',
  'encryption.legacy_format_support' => false,
  'encryption.key_storage_migrated' => false,
  'default_phone_region' => 'DE',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_domain' => 'my_domain',
  'mail_from_address' => 'noreply',
  'mail_smtphost' => 'my_domain.com',
  'mail_smtpname' => 'admin@my_domain.com',
  'mail_smtppassword' => 'xxxxxxxxx',
  'mail_smtpport' => '587',

are they perhaps some still unsolved setup-messages under your adminaccount?

There are in fact two setup warnings, but I doubt they have anything to do with the problem I’m encountering:

  • Your web server is not properly set up to resolve “/.well-known/webfinger”. Further information can be found in the documentation.
  • Your web server is not properly set up to resolve “/.well-known/nodeinfo”. Further information can be found in the documentation.

well ya, maybe they don’t have to do with your problem… But it’s better to solve those warning-messages, though.

As for your problem: have you tried sudo -u [webuser] php occ db:add-missing-tables and sudo -u [webuser] php occ db:add-missing-indices on commandline-level?

Even after fixing all setup warning and running those two commands, nothing has changed. They apparently do not do anything for the calendar app. I also tried reinstalling the calendar app, but to no avail.

This is the complete error log: https://pastebin.com/JudeZLuG

ummm… OK. I’m lost here :frowning:

I searched the forum for other issues like that and came up with only a few threads. Most of them stay unsolved. One guy said that after de-installing Deck-app he could use calendars again. I dunno if that would help you.

So I suggest to open a very detailed issue on issuetracker under Issues · nextcloud/calendar · GitHub

Pls come back here and post the link to your issue as an answer.

I nevertheless appreciate your help :slightly_smiling_face:

Here’s the link to the GitHub issue I have just opened: SQL error : "column "deleted_at" does not exist" after upgrade to Nextcloud 22 · Issue #4095 · nextcloud/calendar · GitHub