Update to nextcloud 17.01 failed, resultign in a blank screen

I followed the Upgrade via built-in updater version 16 latest to 17.01.
But after the last step (Maintain maintenance mode, No) a blank screen appread
[/details]

Nextcloud version (eg, 12.0.2): 16 latest to 17.01
Operating system and version CENTOS 7:
Apache or nginx version (eg, Apache 2.4.25): httpd-2.4.6-90.el7.centos.x86_64
PHP version (eg, 7.1): PHP 7.3.11 (cli) (built: Oct 22 2019 08:11:04) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.3.11, Copyright © 1999-2018, by Zend Technologies

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Upgrade via built-in updater

This is an error message found in ssl_error_log

Mon Nov 18 12:13:11.512772 2019] [php7:error] [pid 10831] [client 10.5.2.90:53818] PHP Fatal error:  Declaration of OCA\\GroupFolders\\Versions\\VersionsBackend::getVersionFile(OCP\\IUser $user, OCP\\Files\\FileInfo $sourceFile, int $revision): OCP\\Files\\File must be compatible with OCA\\Files_Versions\\Versions\\IVersionBackend::getVersionFile(OCP\\IUser $user, OCP\\Files\\FileInfo $sourceFile, $revision): OCP\\Files\\File in /var/www/wo-lar.com/html/nextcloud/apps/groupfolders/lib/Versions/VersionsBackend.php on line 38
[Mon Nov 18 12:13:11.588000 2019] [proxy:error] [pid 10832] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8009 (localhost) failed
[Mon Nov 18 12:13:11.588072 2019] [proxy:error] [pid 10832] AH00959: ap_proxy_connect_backend disabling worker for (localhost) for 60s
[Mon Nov 18 12:13:11.588111 2019] [proxy_ajp:error] [pid 10832] [client 10.5.2.90:53820] AH00896: failed to make connection to backend: localhost

The output of your Nextcloud log in Admin > Logging:

I cannot access anymore

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' =>
  array (
    0 => 'www.wo-lar.com',
  ),
  'datadirectory' => '/home/nextcloud_data/',
  'dbtype' => 'mysql',
  'version' => '16.0.6.1',
  'overwrite.cli.url' => 'https://www.wo-lar.com/nextcloud',
  'dbname' => 'db-name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '***',
  'dbpassword' => '***',
  'installed' => true,
  'mail_from_address' => '***',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'U-name',
  'mail_smtphost' => 'localhost',
  'mail_smtpport' => '587',
  'maintenance' => false,
  'updater.release.channel' => 'stable',
  'theme' => '',
  'loglevel' => 2,
  'updater.secret' => '***',
);

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Thanks for your help,

Wolfgang

1 Like

Hi Wolfgang,

Are you aware you posted you config.php without removing usernames, passwords and secrets? You should never post that sensitive information! I removed that from your post, however, these details can be assumed to be compromised. Changing the passwords as precautious measure is advised.

To solve your issue, you need to disable the app ‘groupfolders’.
Do you have ssh access to your server? If so, run the following command as root user.
I just assume the user, which your webserver is running with, is ‘www-data’. Change that if your web server is running under another user.

sudo -u www-data php /var/www/wo-lar.com/html/nextcloud/occ app:disable groupfolders

If you don’t have ssh access, you could move the folder
/var/www/wo-lar.com/html/nextcloud/apps/groupfolders
somewhere else (to your home directory for example).

After disabling groupfolders via occ command or by moving the directory, reload your nextcloud web page. You should have access again.
Afterwards runs the update to the latest groupfolders version, or install the latest groupfolders version.

Hello,
I still haven’t upgraded to 17.01 and I’m now on 16.05, two things aren’t clear to me:

  1. should I disable Group Folders, am I going to loose the data and config for the Group Folders actually in use?
  2. performing the upgrade via occ instead of the web-updater solves the issue?
    Thanks you
    Alberto

That was pretty stupid… Thanks for helping.

I do have ssh access to my home server.
The first solution did not work for me.

[root@home groupfolders]# sudo -u apache php /var/www/wo-lar.com/html/nextcloud/occ app:disable groupfoldes
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
No such app enabled: groupfoldes

I moved …groupfolder to ./group and upgrade worked now.

Thank you.

Hi @Bittone

If you disable the app, you don’t loose any files or configs. Configs are stored in the database and by disabling an app no files on the filesystem are removed.

1 Like

I had same blank screen issue caused by groupfolders app. However, I am running Nginx and occ was in another folder. For me the following path worked:
sudo -u www-data php /usr/share/nginx/nextcloud/occ app:disable groupfolders