Update to nc28 made it impossible to log in

Nextcloud version: 28.0.2
Operating system and version: Ubuntu 22.04.3
Apache or nginx version: Apache/2.4.56
PHP version: 8.1.2-1

The issue you are facing:

The web page shows the following error:

## Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

It’s not possible to sign in.

Is this the first time you’ve seen this error?: Y

Steps to replicate it:

  1. Upgrade to latest release
  2. open web UI

The output of your Nextcloud log in Admin > Logging:

Cannot log in

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' => 
  array (
    0 => '***',
    1 => '***',
  ),
  'datadirectory' => '***',
  'overwrite.cli.url' => 'https://***',
  'dbtype' => 'mysql',
  'version' => '28.0.2.5',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'owncloud',
  'dbpassword' => '***',
  'logtimezone' => 'UTC',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'logdateformat' => 'F d, Y H:i:s',
  'log_type' => 'owncloud',
  'trashbin_retention_obligation' => 'auto, 30',
  'filelocking.enabled' => 'true',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0,
  ),
  'appstore.experimental.enabled' => true,
  'updatechecker' => false,
  'default_phone_region' => '***',
  'mail_domain' => '***',
  'mail_from_address' => '***',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => '***',
  'mail_smtpauth' => 1,
  'mail_smtpport' => '465',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpname' => '***',
  'mail_smtppassword' => '***',
  'updater.secret' => ***',
);

The output of your Apache/nginx/system log in /var/log/____:

nothing

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

{"reqId":"roUgntei1i1kBe07LlSB","level":1,"time":"February 04, 2024 22:14:55","remoteAddr":"87.158.42.142","user":"--","app":"no app in context","method":"GET","url":"/status.php","message":"Unable to generate a URL for the named route \"settings.Help.help\" as such route does not exist.","userAgent":"Mozilla/5.0 (Linux) mirall/3.10.0git (Nextcloud, debian-6.5.0-5-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":"28.0.2.5","exception":{"Exception":"Symfony\\Component\\Routing\\Exception\\RouteNotFoundException","Message":"Unable to generate a URL for the named route \"settings.Help.help\" as such route does not exist.","Code":0,"Trace":[{"file":"/var/www/nextcloud/lib/private/Route/Router.php","line":380,"function":"generate","class":"Symfony\\Component\\Routing\\Generator\\UrlGenerator","type":"->"},{"file":"/var/www/nextcloud/lib/private/Route/CachingRouter.php","line":65,"function":"generate","class":"OC\\Route\\Router","type":"->"},{"file":"/var/www/nextcloud/lib/private/URLGenerator.php","line":103,"function":"generate","class":"OC\\Route\\CachingRouter","type":"->"},{"file":"/var/www/nextcloud/lib/private/NavigationManager.php","line":233,"function":"linkToRoute","class":"OC\\URLGenerator","type":"->"},{"file":"/var/www/nextcloud/lib/private/NavigationManager.php","line":131,"function":"init","class":"OC\\NavigationManager","type":"->"},{"file":"/var/www/nextcloud/apps/theming/lib/ThemingDefaults.php","line":199,"function":"getAll","class":"OC\\NavigationManager","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Defaults.php","line":271,"function":"getShortFooter","class":"OCA\\Theming\\ThemingDefaults","type":"->"},{"file":"/var/www/nextcloud/lib/public/Defaults.php","line":176,"function":"getLongFooter","class":"OC_Defaults","type":"->"},{"file":"/var/www/nextcloud/core/templates/layout.guest.php","line":51,"function":"getLongFooter","class":"OCP\\Defaults","type":"->"},{"file":"/var/www/nextcloud/lib/private/Template/Base.php","line":180,"args":["/var/www/nextcloud/core/templates/layout.guest.php"],"function":"include"},{"file":"/var/www/nextcloud/lib/private/Template/Base.php","line":150,"function":"load","class":"OC\\Template\\Base","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Template.php","line":139,"function":"fetchPage","class":"OC\\Template\\Base","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Template.php","line":170,"function":"fetchPage","class":"OC_Template","type":"->"},{"file":"/var/www/nextcloud/lib/private/Template/Base.php","line":132,"function":"fetchPage","class":"OC_Template","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Template.php","line":291,"function":"printPage","class":"OC\\Template\\Base","type":"->"},{"file":"/var/www/nextcloud/lib/base.php","line":456,"function":"printExceptionErrorPage","class":"OC_Template","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":705,"function":"initSession","class":"OC","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":1200,"function":"init","class":"OC","type":"::"},{"file":"/var/www/nextcloud/status.php","line":37,"args":["/var/www/nextcloud/lib/base.php"],"function":"require_once"}],"File":"/var/www/nextcloud/3rdparty/symfony/routing/Generator/UrlGenerator.php","Line":144,"message":"Unable to generate a URL for the named route \"settings.Help.help\" as such route does not exist.","exception":{},"CustomMessage":"Unable to generate a URL for the named route \"settings.Help.help\" as such route does not exist."}}
{"reqId":"roUgntei1i1kBe07LlSB","level":1,"time":"February 04, 2024 22:14:55","remoteAddr":"87.158.42.142","user":"--","app":"no app in context","method":"GET","url":"/status.php","message":"Unable to generate a URL for the named route \"files.view.index\" as such route does not exist.","userAgent":"Mozilla/5.0 (Linux) mirall/3.10.0git (Nextcloud, debian-6.5.0-5-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":"28.0.2.5","exception":{"Exception":"Symfony\\Component\\Routing\\Exception\\RouteNotFoundException","Message":"Unable to generate a URL for the named route \"files.view.index\" as such route does not exist.","Code":0,"Trace":[{"file":"/var/www/nextcloud/lib/private/Route/Router.php","line":380,"function":"generate","class":"Symfony\\Component\\Routing\\Generator\\UrlGenerator","type":"->"},{"file":"/var/www/nextcloud/lib/private/Route/CachingRouter.php","line":65,"function":"generate","class":"OC\\Route\\Router","type":"->"},{"file":"/var/www/nextcloud/lib/private/URLGenerator.php","line":103,"function":"generate","class":"OC\\Route\\CachingRouter","type":"->"},{"file":"/var/www/nextcloud/lib/private/NavigationManager.php","line":374,"function":"linkToRoute","class":"OC\\URLGenerator","type":"->"},{"file":"/var/www/nextcloud/lib/private/NavigationManager.php","line":131,"function":"init","class":"OC\\NavigationManager","type":"->"},{"file":"/var/www/nextcloud/apps/theming/lib/ThemingDefaults.php","line":199,"function":"getAll","class":"OC\\NavigationManager","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Defaults.php","line":271,"function":"getShortFooter","class":"OCA\\Theming\\ThemingDefaults","type":"->"},{"file":"/var/www/nextcloud/lib/public/Defaults.php","line":176,"function":"getLongFooter","class":"OC_Defaults","type":"->"},{"file":"/var/www/nextcloud/core/templates/layout.guest.php","line":51,"function":"getLongFooter","class":"OCP\\Defaults","type":"->"},{"file":"/var/www/nextcloud/lib/private/Template/Base.php","line":180,"args":["/var/www/nextcloud/core/templates/layout.guest.php"],"function":"include"},{"file":"/var/www/nextcloud/lib/private/Template/Base.php","line":150,"function":"load","class":"OC\\Template\\Base","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Template.php","line":139,"function":"fetchPage","class":"OC\\Template\\Base","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Template.php","line":170,"function":"fetchPage","class":"OC_Template","type":"->"},{"file":"/var/www/nextcloud/lib/private/Template/Base.php","line":132,"function":"fetchPage","class":"OC_Template","type":"->"},{"file":"/var/www/nextcloud/lib/private/legacy/OC_Template.php","line":291,"function":"printPage","class":"OC\\Template\\Base","type":"->"},{"file":"/var/www/nextcloud/lib/base.php","line":456,"function":"printExceptionErrorPage","class":"OC_Template","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":705,"function":"initSession","class":"OC","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":1200,"function":"init","class":"OC","type":"::"},{"file":"/var/www/nextcloud/status.php","line":37,"args":["/var/www/nextcloud/lib/base.php"],"function":"require_once"}],"File":"/var/www/nextcloud/3rdparty/symfony/routing/Generator/UrlGenerator.php","Line":144,"message":"Unable to generate a URL for the named route \"files.view.index\" as such route does not exist.","exception":{},"CustomMessage":"Unable to generate a URL for the named route \"files.view.index\" as such route does not exist."}}

I can not believe that.
You should find the apache2 error log, usually located in

/var/log/apache2/error.log

The two entries from the nextcloud log are unrelated level 1 entries.


Is your redis-server up and running?


ernolf

with nothing I meant nothing obvious, anyways, here is the error log:

[Sun Feb 04 00:00:02.621199 2024] [mpm_prefork:notice] [pid 3287] AH00163: Apache/2.4.56 (Debian) OpenSSL/1.1.1w configured -- resuming normal operations
[Sun Feb 04 00:00:02.621292 2024] [core:notice] [pid 3287] AH00094: Command line: '/usr/sbin/apache2'
[Sun Feb 04 01:50:41.526643 2024] [php:error] [pid 15811] [client 116.118.49.66:44196] script '/var/www/nextcloud/wp-login.php' not found or unable to stat, referer: http://ud-dd.ddns.net/wp-login.php
[Sun Feb 04 01:57:31.778945 2024] [core:error] [pid 15810] [client 85.198.8.98:35240] AH10244: invalid URI path (/cgi-bin/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/bin/sh)
[Sun Feb 04 01:57:32.298166 2024] [core:error] [pid 15813] [client 85.198.8.98:35242] AH10244: invalid URI path (/cgi-bin/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/bin/sh)
[Sun Feb 04 02:50:34.127893 2024] [core:error] [pid 17126] [client 68.183.225.244:59538] AH10244: invalid URI path (/cgi-bin/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/bin/sh)
[Sun Feb 04 02:50:34.793778 2024] [core:error] [pid 15812] [client 68.183.225.244:59548] AH10244: invalid URI path (/cgi-bin/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/bin/sh)
[Sun Feb 04 02:50:37.077082 2024] [core:error] [pid 15813] [client 68.183.225.244:50646] AH10244: invalid URI path (/cgi-bin/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/bin/sh)
[Sun Feb 04 02:50:38.269848 2024] [core:error] [pid 15811] [client 68.183.225.244:50662] AH10244: invalid URI path (/cgi-bin/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/bin/sh)
[Sun Feb 04 07:19:55.595269 2024] [core:error] [pid 15814] [client 85.198.8.98:37530] AH10244: invalid URI path (/cgi-bin/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/.%2e/bin/sh)
[Sun Feb 04 07:19:56.082683 2024] [core:error] [pid 15811] [client 85.198.8.98:37532] AH10244: invalid URI path (/cgi-bin/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/%%32%65%%32%65/bin/sh)
[Sun Feb 04 09:24:26.194171 2024] [php:error] [pid 16332] [client 159.203.36.119:58622] script '/var/www/nextcloud/alive.php' not found or unable to stat
[Sun Feb 04 17:53:58.740521 2024] [php:error] [pid 15812] [client 92.205.10.134:22390] script '/var/www/nextcloud/wp-login.php' not found or unable to stat, referer: http://ud-dd.ddns.net/wp-login.php
[Sun Feb 04 21:14:43.079494 2024] [mpm_prefork:notice] [pid 3287] AH00170: caught SIGWINCH, shutting down gracefully
[Sun Feb 04 21:14:43.447615 2024] [mpm_prefork:notice] [pid 4171] AH00163: Apache/2.4.56 (Debian) OpenSSL/1.1.1w configured -- resuming normal operations
[Sun Feb 04 21:14:43.447833 2024] [core:notice] [pid 4171] AH00094: Command line: '/usr/sbin/apache2'
[Sun Feb 04 21:16:29.995424 2024] [mpm_prefork:notice] [pid 4171] AH00170: caught SIGWINCH, shutting down gracefully
[Sun Feb 04 21:16:30.329828 2024] [mpm_prefork:notice] [pid 4227] AH00163: Apache/2.4.56 (Debian) OpenSSL/1.1.1w configured -- resuming normal operations
[Sun Feb 04 21:16:30.330050 2024] [core:notice] [pid 4227] AH00094: Command line: '/usr/sbin/apache2'
[Sun Feb 04 21:17:24.525153 2024] [mpm_prefork:notice] [pid 4227] AH00170: caught SIGWINCH, shutting down gracefully
[Sun Feb 04 21:17:24.852620 2024] [mpm_prefork:notice] [pid 4266] AH00163: Apache/2.4.56 (Debian) OpenSSL/1.1.1w configured -- resuming normal operations
[Sun Feb 04 21:17:24.852848 2024] [core:notice] [pid 4266] AH00094: Command line: '/usr/sbin/apache2'
[Sun Feb 04 21:25:59.379402 2024] [mpm_prefork:notice] [pid 4266] AH00170: caught SIGWINCH, shutting down gracefully
[Sun Feb 04 21:26:01.571819 2024] [mpm_prefork:notice] [pid 4422] AH00163: Apache/2.4.56 (Debian) OpenSSL/1.1.1w configured -- resuming normal operations
[Sun Feb 04 21:26:01.572038 2024] [core:notice] [pid 4422] AH00094: Command line: '/usr/sbin/apache2'
[Sun Feb 04 21:54:15.726363 2024] [php:notice] [pid 4425] [client 87.158.42.142:51002] {"reqId":"kJLVTq262z8FxeK5f8QG","level":3,"time":"2024-02-04T21:54:15+00:00","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/204","message":"touch(): Utime failed: Permission denied at /var/www/nextcloud/lib/private/Config.php#275","userAgent":"Mozilla/5.0 (Linux) mirall/3.10.0git (Nextcloud, debian-6.5.0-5-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":"","data":{"app":"PHP"}}
[Sun Feb 04 21:54:15.735769 2024] [php:notice] [pid 4425] [client 87.158.42.142:51002] {"reqId":"kJLVTq262z8FxeK5f8QG","level":3,"time":"2024-02-04T21:54:15+00:00","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/204","message":"fopen(/var/www/nextcloud/config/config.php): Failed to open stream: Permission denied at /var/www/nextcloud/lib/private/Config.php#276","userAgent":"Mozilla/5.0 (Linux) mirall/3.10.0git (Nextcloud, debian-6.5.0-5-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":"","data":{"app":"PHP"}}
[Sun Feb 04 21:54:15.735968 2024] [php:notice] [pid 4425] [client 87.158.42.142:51002] {"reqId":"kJLVTq262z8FxeK5f8QG","level":3,"time":"2024-02-04T21:54:15+00:00","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/204","message":"chmod(): Operation not permitted at /var/www/nextcloud/lib/private/Config.php#279","userAgent":"Mozilla/5.0 (Linux) mirall/3.10.0git (Nextcloud, debian-6.5.0-5-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":"","data":{"app":"PHP"}}
[Sun Feb 04 21:54:15.940016 2024] [php:notice] [pid 4425] [client 87.158.42.142:51002] {"reqId":"kJLVTq262z8FxeK5f8QG","level":3,"time":"2024-02-04T21:54:15+00:00","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/204","message":"fopen(/var/www/nextcloud/data/nextcloud.log): Failed to open stream: No such file or directory at /var/www/nextcloud/lib/private/Log/File.php#82","userAgent":"Mozilla/5.0 (Linux) mirall/3.10.0git (Nextcloud, debian-6.5.0-5-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":"","data":{"app":"PHP"}}

And yes, redis is up and running.

I also see these log messages:

{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"Composer detected issues in your platform: Your Composer dependencies require a 64-bit build of PHP. at /var/www/nextcloud/apps/suspicious_login/vendor/composer/platform_check.php#28","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"ini_set(): Session ini settings cannot be changed after headers have already been sent at /var/www/nextcloud/lib/base.php#431","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"ini_set(): Session ini settings cannot be changed after headers have already been sent at /var/www/nextcloud/lib/base.php#435","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"ini_set(): Session ini settings cannot be changed after headers have already been sent at /var/www/nextcloud/lib/base.php#439","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"base","method":"GET","url":"/index.php/login","message":"Failed to start session","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","exception":{"Exception":"Exception","Message":"Failed to start session","Code":0,"Trace":[{"file":"/var/www/nextcloud/lib/base.php","line":446,"function":"__construct","class":"OC\\Session\\Internal","type":"->"},{"file":"/var/www/nextcloud/lib/base.php","line":705,"function":"initSession","class":"OC","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":1200,"function":"init","class":"OC","type":"::"},{"file":"/var/www/nextcloud/index.php","line":37,"args":["/var/www/nextcloud/lib/base.php"],"function":"require_once"}],"File":"/var/www/nextcloud/lib/private/Session/Internal.php","Line":62,"message":"Failed to start session","exception":{},"CustomMessage":"Failed to start session"}}

That is very obvious:

Permission denied messages.

Check the file permissions and -ownership


ernolf

The file permission looks good to me.

ll nextcloud.log 
-rw-r----- 1 www-data www-data 91756 Feb  4 23:13 nextcloud.log

Maybe it was a one time issue, because I don’t get these errors anymore when I restart apache.

Can this be a problem?:

{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"Composer detected issues in your platform: Your Composer dependencies require a 64-bit build of PHP. at /var/www/nextcloud/apps/suspicious_login/vendor/composer/platform_check.php#28","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"ini_set(): Session ini settings cannot be changed after headers have already been sent at /var/www/nextcloud/lib/base.php#431","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"ini_set(): Session ini settings cannot be changed after headers have already been sent at /var/www/nextcloud/lib/base.php#435","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"PHP","method":"GET","url":"/index.php/login","message":"ini_set(): Session ini settings cannot be changed after headers have already been sent at /var/www/nextcloud/lib/base.php#439","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","data":{"app":"PHP"}}
{"reqId":"jWN0CMj6Fhm6aUpaJvV5","level":3,"time":"February 04, 2024 22:52:54","remoteAddr":"87.158.42.142","user":"--","app":"base","method":"GET","url":"/index.php/login","message":"Failed to start session","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0","version":"28.0.2.5","exception":{"Exception":"Exception","Message":"Failed to start session","Code":0,"Trace":[{"file":"/var/www/nextcloud/lib/base.php","line":446,"function":"__construct","class":"OC\\Session\\Internal","type":"->"},{"file":"/var/www/nextcloud/lib/base.php","line":705,"function":"initSession","class":"OC","type":"::"},{"file":"/var/www/nextcloud/lib/base.php","line":1200,"function":"init","class":"OC","type":"::"},{"file":"/var/www/nextcloud/index.php","line":37,"args":["/var/www/nextcloud/lib/base.php"],"function":"require_once"}],"File":"/var/www/nextcloud/lib/private/Session/Internal.php","Line":62,"message":"Failed to start session","exception":{},"CustomMessage":"Failed to start session"}}

That’s one of the error messages. Are you using a 32 bit version of PHP?

Try disabling / removing the suspicious_login app.

1 Like

I have an armv7l processor, so only 32bit. Is that not supported anymore?

Disabling the suspicious_login app did the trick. Thanks a lot!

So it sounds like a bug in the app, right? Is this already addressed somewhere?

Related bug report is here: Investigate feasibility of use in 32-bit environments · Issue #837 · nextcloud/suspicious_login · GitHub.
Right now the app seems to be 64bit only, but actually still advertises 32 bit support in its manifest which causes Nextcloud to install an update wich won’t work on your device.

1 Like

alright, thanks for the clarification.

Indeed.

A third-party tool (Composer) recently started enforcing a parameter (that’s been in place for a long time) that prevents this app from being deployed in non-64-bit environments).

Since it wasn’t being enforced it kinda/sorta worked for 32-bit environments and nobody noticed because it functioned fine unless you used it with IPv6.

But now since the parameter we had in place is being enforced, it also won’t install or upgrade that app in 32-bit environments, which poses a dilemma for existing installations.

It’s being worked on.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.