"Update to buster available" despite Debian version 10.10

After having my data disk die and the restore of a full nc-data plus data fail, I have now got things back up running, which included updating to buster. However, when I log in to the pi, the message Update to buster available still appears.

Any ideas how I can correct this (and even get it to let me know when the update to bullseye is available)?