Update to 28.0.0 Beta 3 reports that I am missing bz2 PHP module, when I am not

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 28.0.0 Beta 3
Operating system and version (eg, Ubuntu 20.04): Debian bullseye on RPI 4
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.56
PHP version (eg, 7.4): 8.2.12

The issue you are facing:

  • This instance is missing some recommended PHP modules. For improved performance and better compatibility it is highly recommended to install them: bz2. For more details see the documentation :arrow_upper_right:.

Is this the first time you’ve seen this error? Y:

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocv55pefxxlt',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'www.mumrobo.me.uk',
    1 => 'mumrobo.ddns.net',
    2 => '',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://www.mumrobo.me.uk/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'mumrobo',
  'dbpassword' => 'Mina2014',
  'installed' => true,
  'updater.release.channel' => 'beta',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'encryption.legacy_format_support' => false,
  'encryption.key_storage_migrated' => false,
  'app_install_overwrite' => 
  array (
    0 => 'contacts',
    1 => 'audioplayer',
    2 => 'bruteforcesettings',
    3 => 'richdocuments',
    4 => 'carnet',
    5 => 'music',
  'default_phone_region' => 'GB',
  'mail_from_address' => 'ksaro1',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'plusdsl.com',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'relay.plus.net',
  'mail_smtpport' => '587',
  'mail_smtpname' => 'ksaro1',
  'mail_smtppassword' => 'h0sebeast',
  'mail_smtpauthtype' => 'LOGIN',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'preview_max_x' => 1024,
  'preview_max_y' => 1024,
  'updater.secret' => 'xxx',

Hi Alexander,

could you provide the output of:

dpkg -l|awk -F"  |-" '/^ii.*php8.2/{printf"%s,",$3}';echo

Much luck,

$ dpkg -l|awk -F" |-" ‘/^ii.*php8.2/{printf"%s,",$3}’;echo

Seems to be installed.

Did you follow the instructions before updating to Beta 3?:

Much luck,

But is it also enabled? In PHP, for cli and web.

1 Like

What is the output of

apachectl -tD DUMP_INCLUDES | sed -n '/php.*conf/ s#.*/\([^/]*\)\.conf#\1#p'

Much luck,

Sorry for the delay, I’ve been away.

$ apachectl -tD DUMP_INCLUDES | sed -n ‘/php.conf/ s#./([^/]*).conf#\1#p’

I’ve also just updated to RC2 and still get the warning about bz2. I see that my active php version (php -v) is 8.3. I also now get the cron job failing unless I run it as php8.2. Is this expected?

It is not recommended to deal with beta software if you do not master the basics of server administration.

Now I know exactly how your problem arised and I will try to explain it as short as possible…

Read this:

Much luck,

php-updater -h

Dependency not met!

missing dependency:

Bynary Package Description

jq jq command-line JSON processor

please install first

sudo apt-get install jq

Much luck,