Update to 13.0.2 - The following places can not be written to:


Went to run the upgrade to 13.0.2 from 13.0.1 via the GUI and got the following error:-

Check for write permissions
The following places can not be written to:

There were lots of other files in the updater directory listed.

I looked at the permissions on the directory and they were
drwxr-x— 2 www-data www-data 4096 Mar 13 18:48 updater

I tried changing it to

drwxrwxrw- 2 www-data www-data 4096 Mar 13 18:48 updater

but still get the same error. By now you can probably tell, i am not a Linux expert, so if someone can tell me what the permissions on this folder should be, that would be great.



Following the recomendation from this:-

Solved the problem

chown -R www-data:www-data /var/www/nextcloud



1 Like

Have the same issue and how it solved does not pass to what this script does:

Basically I’m really confused, because of web updater I have to set some strange permissions…

Worked for me too thanks.

After changing these permissions does this leave us vunerable? do we need to change anything back?

After update you can run https://github.com/nextcloud/vm/blob/master/static/setup_secure_permissions_nextcloud.sh to restore secure permissions.

Solution is easy
the Directory nextcloud/updater seem to be writable

in the directory “nextcloud” on your webspace, you have 2 Files
visible by SSH Login with “ls -la”
these file change Group and User from root to you local webuser (check the others files how it is named)
Than start the update from 13 to 14 version
so this directory check from the updater will pass

After update, change these 2 files back to Group and User “root”
Function super good on my server

i dont change group and users recursive all my directories on a web server, this is data suicide !

Why this error appears ??
by checking these to files from the upgrade script, the script is telling the programm to hop back, from Updater directory back to Nextcloud directory

/var/www/yourwebsite/nextcloud/updater/…/.user.ini <<<<<YOU SEE THE POINTs

this is giving the update the order , go back to nextcloud directory and check the file .user.ini for beeing writable
nothing strange in programming, but hell for normal webadmin…

Thank you dude, same issue found updating from 20.0.5 to 20.0.6, solved with
chown -R www-data:www-data /var/www/nextcloud