Update Problem - Check for expected files

Bei einem aktuellen Webupdate Versuch von Nextcloud 10.0.1 auf 10.0.2 erscheint bei mir folgender Fehler:

Check for expected files The following extra files have been found:stats

In der ERROR Log steht:
Error PHP Undefined index: MemAvailable at /var/www/clients/client123/web123/web/apps/serverinfo/lib/SystemStatistics.php#85

PHP Version: 7.0.11

Was ist das Problem?

2 Likes

Hat keiner eine Idee oder dieses Problem schonmal gehabt?

Wenn extra-files gefunden wurden, am besten diese Dateien löschen.

Falls da allein nicht hilft, kannst du vorübergehend die serverinfo-app deaktivieren.

Welche Files muss ich denn bei der obigen Meldung löschen? Den Ordner “stats” ???
Deaktivierung der serverinfo-app hat keine Verbesserung gebracht.

Normalerweise zeigt er etwas mehr Infos an, welchen Hash er erwartet und welchen die Datei wirklich hat. Oder ist das einfach nur ein leeres Verzeichnis? Eventuell ist das stats-Verzeichnis ein Unterverzeichnis von apps?

Hallo!

Habe das gleiche Problem. Gibt es da nittlerweile eine Lösung? Liegt es vielleicht an einem SSL-Proxy?

Hallo zusammen,

ich habe das gleiche Problem. Ich bin auf einem Shared-Webhoster (all-inkl.com) und versuche von einer NC 10.0.1 Version per Online Updater auf die Version 10.0.2 bzw. dann auf die V11 zu kommen.
ABER da ich das ganze in einer Subdomain im root-Verzeichnis installiert habe, komme ich jetzt leider nicht weiter wie zum ersten Schritt und der sagt dann immer:

Check for expected files
The following extra files have been found:
cgi-bin
tmp
logs
usage

TJA und diese Ordner! (keine Dateien) kann ich leider nicht löschen, da sie vom Provider in JEDEM root-Verzeichnis liegen… :cry:

UND nun???
über hilfe würde ich mich und meine Vorredner SEHR freuen! DANKE :wink:

Achja, da fällt mir gerade noch ein, damals bei der Installation musste ich in der config/config.php Datei folgenden Eintrag machen:
‘integrity.check.disabled’ => true,
sonst ging das damals auch nicht… übernimmt das der Updater NICHT?

cu Ralf

P.S die “Manual Nextcloud Upgrade” Anleitung bringt mir leider auch nicht viel, da ich KEINEN Konsolen Zugriff habe.

Moin moin, auch bei mir schlägt das Update von 10.0.1 to 10.0.2 aus der Admin Umgebung der Nextcloud heraus fehl. Die Nextcloud wird von hosteurope gehostet.

Die Meldung ist: Check for expected files
Mit Text: SSL Proxy Server - Die angeforderete Internetseite wird anscheinend nicht auf einem Webhosting Paket von Host Europe betrieben.

Was vielleicht daher rührt, das HostEurope einen Proxy für die SSL mit aber anderem Domainnamen zur Vefügung stellt.

Wie kann ich dennoch den Update-Mechanismus dazu bewegen, das Update einzuspielen?

Dank und Gruss,
jens

Hallo Ralph,
hatte das gleiche Problem mit 10.0.1 bei allinkl:

Check for expected files
The following extra files have been found:
tmp

Lösung:
bin übers KAS und WEB-FTP in den Ordner der nextCloud Installation und habe dort das tmp Verzeichnis (also in meinem USER-Bereich) gelöscht,
dann ging 10.0.1 auf 10.02 und anschießend 10.0.2 auf 11.0.0 problemlos.

Gruß
Franc

1 Like

Hallo! Das klingt doch schon einmal gut. Kannst du bitte noch einmal genau sagen, wo du den tmp Ordner gelöscht hast? Danke!

LG!
Sebastian

Hallo Sebastian,

der tmp-Ordner war im Verzeichnisbaum: w00xyz / “domain” / nextCloud / , also im Installationsverzeichnis von nextcloud.

Gruß
Franc

1 Like

Bei mir war die Meldung “Check for expected files The following extra files have been found:stats” nun auch weg, nachdem ich den Ordner “stats” gelöscht habe.

Es hängt dann aber im Schritt: "Check for write permissions"
SplFileInfo::isDir(): open_basedir restriction in effect…

Was ist das denn nun?

Genau an der gleichen Stelle stehe ich jetzt auch.

SplFileInfo::isDir(): open_basedir restriction in effect. File(…/cloud/updater/…/…) is not within the allowed path(s):

Warum will denn Nextcloud wissen ob sich das Projekt in einem Verzeichnis befindet? Sorry, aber Nextcloud hat in dem darüber liegenden Ordner nix zu suchen!

Hallo Frank,

naja dann scheinst du deine Nextcloud installation aber NICHT in einem “root” Verzeichnis gemacht zu haben, sondern in einem Unterordner. Und ja den Ordner “tmp” könnte ich bei all-inkl über das web-ftp löschen. Jedoch die anderen drei Ordner (cgi-bin, logs & usage) leider NICHT, da dies Systemordner sind und die all-inkl in jedem root-Verzeichnis braucht!!

Ich habe auch schon hier eine Anfrage auf github gestellt:

Aber ich vermute, dass @LukasReschke aus Sicherheitsgründen keine Möglichkeit für uns schaffen wird diesen Schritt der “Check for expected files” zu umgehen :frowning: schade schade schade. Denn bei einer Installation ist es ja bereits möglich diesen Schritt zu umgehen, mit dem Parameter ‘integrity.check.disabled’ => true,

Danke cu Ralf

Hallo,

auch ich bin bei ALL-INKL und habe Nextcloud unter einer Subdomain (box.EINEDOMAIN.de) installiert.
Im entsprechneden Ordner (bei mir /sub/EINEDOMAIN/box/) kann ich die die Ordner cgi-bin, logs und tmp gefahrlos löschen, werden ja nicht gebraucht. den Ordner usage verschiebe ich via WebFTP für das Update eine Ordnerebene hoch und nach dem Update wieder runter.
Hat letztendlich problemlos funktioniert.
Ich vermute das klappt auch bei einer Domain wenn diese nachträglich nicht mehr auf Root zeigen lässt. Das mache ich so bei allen, dadurch erhalte ich zudem eine Ebene die nicht von außen über die Domains erreichbar ist.

Ich hoffe ich konnte helfen
Michael

1 Like

Hallo Michael,

bin ebenfalls bei All-Inkl, es reichte den Ordner tmp im Nextcloutverzeichnis zu löschen.

Hallo!
Ich bin auch bei All-Inkl, habe Nextcloud 11.0.0 installiert und wollte nun auf 11.0.2 automatisch updaten.
Den tmp-Ordner habe ich gelöscht, aber jetzt kommt, immer noch beim Schritt “Check for expected files”, der Fehler

Parsing response failed.

Hat irgendwer die gleiche Erfahrung gemacht und eine Idee, was man dagegen tun kann?

To your on risk:

Open file https://yourserver/yournextcloudir/updater/index.php
search for getExpectedElementsList()
Update list that it fits to your needs
Save it
Update Nextcloud with automatic updater
done

your change to this files gets reverted during update to the release version, but update worked to new release

2 Likes

Ich hatte soeben dasselbe Problem beim Update auf V12.0.1
Mein Hoster ist ebenfalls Host Europe und ich nutze den SSL Proxy “https://ssl.webpack.de/”. Das Problem scheint durch den SSL Proxy verursacht zu werden. Der Fix ist relativ simpel. Einfach in der config.php vorübergehend die Zeilen für das overwrite… auskommentieren. Bei mir sind dies:

//‘overwritehost’ => ‘ssl.webpack.de’,
//‘overwriteprotocol’ => ‘https’,
//‘overwritewebroot’ => ‘/[meine URL]’,

Damit lief der Updater einwandfrei durch.
Ich habe mir einfach eine 2. config.php gebastelt welche ich nun bei Updates umbenennen kann, so muss ich nicht jedesmal lange überlegen. Hoffe dies hilft Anderen die wie ich über die Suche hier landen.
Gruss Patrick

1 Like

@grzchr15: Thank you so much. With this hint I could finally upgrade to latest version