Update not available

Hi
I’m running NC 19.0.5 on stable channel with the Docker installed on a Raspbian Buster.
I got this morning through the NC windows client a notification that 19.0.6 was delivered, so I went to the admin overview, and indeed I’m seeing (soory in French but easily understandable in the context)
image
But when I try to do the update whether through the UI or though the CLI, it tells me the 19.0.5 version is up-to-date and there is nothing to do:
image
or

pi@raspberrypi ~ $ update_nextcloud
Nextcloud Updater - version: v19.0.3-8-gbfdc40b

Current version is 19.0.5.

No update available.

Nothing to do.

I first tried with the stable channel, and it didn’t work so I tried with the beta channel, but not working better (and even weirder, It should show some 20.X version in this channel)…

Any clue?

Update your docker image?

1 Like

The docker image update doesn’t update the nextcloud version itself as far as I know. Nextcloud is in a separate volume.
Usually, I have to update manually.

FYI, several hours later, I still get the same error.

This is precisely what Docker does do.

  1. Pull the latest image, from wherever you prefer.
  2. Stop and rm your docker container.
  • All actual /data lives on in it’s designated volume
    • Volumes live on the file system
    • Containers are built directly from the image you’ve pulled
    • Your run command (or docker-compose) is what allows your container to know the volume exists at all.
  1. Start up the latest container!

Hi @just
Sorry but precisely this does not work like you say:
I’m using the https://hub.docker.com/r/linuxserver/nextcloud image, and the documentation says:

Docker image update and recreation of container alone won’t update nextcloud version.

In order to update nextcloud version, you have two options, firstly make sure you are using the latest docker image,then either

  1. Perform the in app gui update.
  2. Use the CLI version by running docker exec -it nextcloud updater.phar (Both of these are described here)

I update my images daily automatically with “docker-compose up -d” since months and it works pretty well.

Anyway, this morning I had again the message that 19.0.6 version was delivered AND I was able to do the update.

pi@raspberrypi ~ $ update_nextcloud
Nextcloud Updater - version: v19.0.3-8-gbfdc40b

Current version is 19.0.5.

Update to Nextcloud 19.0.6 available. (channel: "beta")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-19.0.6.zip
Open changelog ↗

Updater run in non-interactive mode.

Start update

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[ ] Downloading ...

So, issue closed but still I do not understand what happened…

yes. you are right. that one is different from the “official” nextcloud image.