Update nicht möglich

Hallo,

Ich habe ein Problem das nextcloud Update durchzufĂŒhren. Ich benutze derzeit Nx 24.0.3 und jedes Mal, wenn ich auf den Update Button klicke scrollt die Seite nur nach oben. Leider funktioniert auch das Update ĂŒber den Terminal nicht.

Ich habe die nextcloud auf einem synology Server installiert mit php8.0 und Apache2.4 und bis vor kurzem nie Probleme damit.

Ich freue mich ĂŒber eure Hilfe.

Welchen Fehler hast du bei
sudo -u www-data php /pfad/zur/nextcloud/updater/updater.phar
(evtl. Benutzername www-data anpassen)

es erscheint die Nachricht:
Failed to open stream: Permission denied in phar:///weg/zur/nextcloud/updater/updater.phar/lib/Updater.php on line 1128
Could not open updater.log

Eigentlich einfach. Dein Webserver/Nextcloud-Benutzer hat keine Rechte auf den Ordner/die Datei wo updater.log steht.

Bei Debian/Ubuntu:

sudo chown -R www-data:www-data /weg/zur/nextcloud

Wahrscheinlich hast du irgendwann mal als root in dem Ordner rumgeÀndert.

hat geholfen, aber nun bekomme ich diese Fehlermeldung:
Verify integrity 
PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 151137848 bytes) in phar:///volume1/web/nextcloud/updater/updater.phar/lib/Updater.php on line 655

ZusÀtzlich bekomme ich jz beim updateversuch auch noch die Meldung:
Step 5 is currently in process. Please call this command later.

kenne leider nicht den richtigen Befehl dafĂŒr

FĂŒr Memory lese hier. Vielleicht eine Idee.

Der “Step 5” steht in einer Datei “.step”. Evtl. die Datei mal löschen (oder umbenennen).

hat geholfen und die Nextcloud ist jetzt auf der aktuellsten Version, aber ich kann die Nextcloud nicht mehr aufrufen, weil jedes mal deer Fehler 403 “Bei der Verarbeitung dieser Anforderung ist ein Fehler aufgetreten.” kommt


Schau mal in den Logs. Vielleicht findest du da was.
/pfad/zur/nextcloud/data/nextcloud.log
Wenn dort nichts steht evtl. Loglevel hochsetzen.

Manchmal gibt es auch ein paar andere Fehlermeldungen, wenn du das PHP-Script manuell aufrust. Verwende ich aber eher aus Verzweiflung. :wink:
sudo -u www-data php /pfad/zur/nextcloud/index.php

Oder vielleicht
sudo -u www-data php /pfad/zur/nextcloud/occ maintenance:repair
Hilft vielleicht nicht, gibt aber vielleicht ein paar Meldungen. :wink:
Dokumentation

Oder mal booten. Der Windows-Weg.

bekomme bei jedem maintenance Befehl leider immer die gleiche Meldung.
"An unhandled exception has been thrown:

OCP\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)"

entschuldige, dass ich hier immer Hilfe brauche
 :frowning:

Entweder installierst du das Paket php-apcu (bitte als Erstes probieren)
oder du löscht folgende Zeile in config/config.php:
'memcache.local' => '\OC\Memcache\APCu',

Dokumentation

Falls es nicht erfolgreich ist, probiere beides aus und poste zu beiden die Fehlermeldungen.

Da ich PHP8 verwende könnte php-apcu nutzlos sein, da es keine Support mehr erhÀlt

Also mit PHP8.0 kenne ich mich nicht aus. Hat wohl damit zu tun, dass es ein “synology Server” bei dir ist. Du kannst ja mal suchen, ob du es installiert bekommst. Und wenn nicht deaktiviere es wie beschrieben in config/config.php. Vielleicht ist ja auch Redis was fĂŒr dich.

Ubuntu 20.04 LTS
php-apcu (PHP 7.4)

Ubuntu 22.04 LTS
php-apcu → php8.1-apcu

Debian 11 Bullseye
php-apcu (PHP 7.4)

Also ich sehe keinen Grund, warum es das nicht mehr fĂŒr PHP8 geben sollte.

Ich konnte es mit dem löschen der Zeile aus der config dann beheben. Vielen Dank :blush:

1 Like