Update Nextcloud Truenas - Internal Server Error

Hello,

I am coming to you because I am using Nextcloud as a plugin with Truenas and I did an update yesterday of TrueNas and Nextcloud and now when I try to connect to NextCloud, I have this error message:

"Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log. "

Do you have any leads to solve this problem?

Thank you.
Regards,
Nicolas

1 Like

First place to look for clues is mostly logs.

Versions,hardware info, maybe link to install procedure used, might help…

Hello,
Thank you for the quick response.

Here are the logs of the file from yesterday’s date.
Sorry, I don’t know how to put them otherwise.

Truenas version: TrueNAS-12.0-U3.1
Thank you so much.

PS : Sorry, I log was big, I put it on a server.

sav_nextcloud.log

Hello,
Would you have a solution for my concern please?
Thank you.
Regards,

I don’t have a solution for your problem, but maybe this thread in the TrueNAS forum can give you some clues what the problem could be…

https://www.truenas.com/community/threads/nextcloud-update-to-21-0.91462/

Any solution, yet?
I have the same issue as well

Thanks

Just found a solution:

go to /usr/local/etc/mysql
edit my.cnf and comment query_cache_type and query_cache_size
start mysql

4 Likes

Same issue, your solution works perfectly.
Thank you very much !

1 Like

Fixed my problem! Thank you so much!

Hello,
Excuse me, I didn’t have time to take care of my worries.

Thanks to all of you for your answers. It’s really kind of you.

Thanks to @stanamas for the solution which worked great !!

Thanks again.
Have a nice day and well done !!!

Thank you very much! This resolved my issue as well

bonjour, possible de détailler la procédure de modification des deux lignes du fichier my.cnf ? a savoir les lignes “query_cache_type” et “query_cache_size”.
dans mon fichier, ces deux ligne se termine par “0”
que dois-je faire ?

New to this whole thing, how do i comment, ive tried setting it to 1 & 0 but no change.

I am a noob when it comes to command/terminal coding