Update Nextcloud scheitert

Liebes Forum,

ich habe zur Zeit nextloudpi v1.51.0 auf einem raspberry pi 4 laufen. Bis gestern war Nextcloud 20 installiert. Das Upgrade auf 25 scheitert: “Updates between multiple major versions are unsupported”. Gut, also zuerst NC 21 und dann NC 22 installiert. Das Upgrade auf 23 scheitert aber nun mit der Meldung: “Nextcloud or one of the apps require upgrade - only a limited number of commands are available”. Anschließend Roll Back des Backups.
Am Punkt “Scanning AppData for files” geht es nicht weiter. Hier schließe ich das Terminal und starte neu.

Hat jemand eine Idee, wie ich das Update auf 23 hinbekomme bzw. woran es hakt?

[logs entfernt]

Das Problem hat sich gelöst, nachdem ich auf die neuste 22er geupdeted habe. Danach ging es Problemlos auf 23. Trotzdem vielen Dank!

2 Likes

Sehr gut das es geklappt hat. Stell am besten deine nextcloud im webui (IP:4443) auf autoupdates. Dann hast auch gar keinen solchen updatestau, was natĂŒrlich auch ein Sicherheitsrisiko ist

Die Autoupdates hatte ich zugunsten der VerfĂŒgbarkeit damals deaktiviert, da es immer wieder zu dem Problem kam, dass die nextcloud hĂ€ufiger mal im Wartungsmodus verblieben ist. Das scheint aber ein bekanntes Problem zu sein?