Update needed - WEB-UI locked

Hi guys,

I suddenly get the following message when accessing the WEB UI:

I used the update script in /var/scripts and also tried it manually via sudo -u www-data php updater/updater.phar without any success as I am on the latest version!

I use the latest stable Hansson appliance.
Do you have any ideas WHY this is suddenly coming up and HOW to solve it?

Hi, I have today the same problem, I have solved with this upgrade and reboot (check your OCC path)

sudo -u www-data php /var/www/nextcloud/occ upgrade

but it’s a solution for today, I’m still looking for how to fix the update automatically …

Thank you, that worked for me as well!

I´m just curious why this happened? Have never seen this message through all the years while using nextcloud. And also what triggered this event?

on which nc-version have you been before? and now it is?

I honestly don’t know, I’ve been using nextcloud for a few days, and I thought it would come out with every update, and I was very worried! I hope, then, not recapitulate in the future, at least until I find how to make him do this update automatically


P.S.: my version is 18.0.3

Has been on 18.0.3 and still is. The command just updated the mail app!
I also enabled automatic updates via the Hansson Script


double uh-huh :wink:

maybe you want to disable automatic updates via hansson script? as this could be the reason. no worries, i’m sure you still will be informed about updates of apps and server.


you are aware of that issue? i saw several auto-update-needed issues on the forum during last days…

This is already reported.

It’s also fixed in the VM: