Update ncp-dist-upgrade

Hello, I’m trying to update sudo ncp-dist-upgrade unfortunately I have the following error

sed: impossible de lire /etc/systemd/system/dhcpcd.service.d/wait.conf: Aucun fichier ou dossier de ce type
Something went wrong. Fix it and try again

Do you know how to fix it?

thank you in advance

on the system folder, I have:

ls /etc/systemd/system
autologin@.service                      graphical.target.wants        rc-local.service.d
bluetooth.target.wants                  halt.target.wants             reboot.target.wants
dbus-fi.w1.wpa_supplicant1.service      log2ram.service               redis.service
dbus-org.bluez.service                  mariadb.service.d             refresh_notify_push.path
dbus-org.freedesktop.Avahi.service      multi-user.target.wants       refresh_notify_push.service
dbus-org.freedesktop.timesync1.service  mysqld.service                remote-fs.target.wants
default.target                          mysql.service                 samba-ad-dc.service
default.target.wants                    ncp-metrics-exporter.service  sockets.target.wants
dhcpcd5.service                         network-online.target.wants   sshd.service
display-manager.service                 nfs-blkmap.service            sysinit.target.wants
dphys-swapfile.service.d                nfs-server.service.d          syslog.service
fail2ban.service.d                      notify_push.service           timers.target.wants
getty.target.wants                      poweroff.target.wants         zram.service
getty@tty1.service.d                    printer.target.wants

on the dhcpcd5.service file, I have:

[Unit]
Description=dhcpcd on all interfaces
Wants=network.target
Before=network.target

[Service]
Type=forking
PIDFile=/run/dhcpcd.pid
ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b
ExecStop=/sbin/dhcpcd -x

[Install]
WantedBy=multi-user.target
Alias=dhcpcd5.service

on the etc folder, I have:

ls /etc/
journald.conf  network        resolved.conf  system       timesyncd.conf  user.conf
logind.conf    networkd.conf  sleep.conf     system.conf  user
pi@paulo:~ $ ls /etc/
adduser.conf            fail2ban           libnl-3         paxctld.conf      sensors.d
aliases                 fake-hwclock.data  libpaper.d      perl              services
aliases.db              fb.modes           lightdm         php               sgml
alsa                    firefox-esr        lighttpd        pip.conf          shadow
alternatives            fonts              locale.alias    plymouth          shadow-
apache2                 fstab              locale.gen      pm                shells
apparmor.d              fuse.conf          localtime       polkit-1          skel
apt                     gai.conf           log2ram.conf    postfix           smartd.conf
avahi                   gdb                logcheck        ppp               smartmontools
bash.bashrc             ghostscript        login.defs      printcap          snmp
bash_completion         glvnd              logrotate.conf  profile           ssh
bash_completion.d       gnome              logrotate.d     profile.d         ssl
bindresvport.blacklist  groff              lynis           protocols         subgid
binfmt.d                group              machine-id      pulse             subgid-
bluetooth               group-             magic           python            subuid
ca-certificates         gshadow            magic.mime      python2.7         subuid-
ca-certificates.conf    gshadow-           mailcap         python3           sudoers
calendar                gss                mailcap.order   python3.7         sudoers.d
chromium-browser        gtk-2.0            manpath.config  rc0.d             sysctl.conf
cifs-utils              gtk-3.0            menu-methods    rc1.d             sysctl.d
console-setup           host.conf          mime.types      rc2.d             systemd
cron.d                  hostname           mke2fs.conf     rc3.d             terminfo
cron.daily              hosts              modprobe.d      rc4.d             timezone
cron.hourly             hosts.allow        modsecurity     rc5.d             timidity
cron.monthly            hosts.deny         modules         rc6.d             tmpfiles.d
crontab                 hp                 modules-load.d  rc.local          triggerhappy
cron.weekly             idmapd.conf        monit           rcS.d             ucf.conf
cups                    ifplugd            mono            redis             udev
cupshelpers             init               motd            request-key.conf  udisks2
dbus-1                  init.d             mtab            request-key.d     ufw
debconf.conf            initramfs-tools    mysql           resolv.conf       update-motd.d
debian_version          inputrc            nanorc          resolvconf        usb_modeswitch.conf
debsums-ignore          insserv.conf.d     netconfig       resolv.conf.bak   usb_modeswitch.d
default                 iproute2           network         resolvconf.conf   vdpau_wrapper.cfg
deluser.conf            issue              networks        rmt               vim
dhcp                    issue.net          Nextcloud       rpc               vnc
dhcpcd.conf             kernel             nsswitch.conf   rpi-issue         vulkan
dictionaries-common     ldap               openal          rsyslog.conf      wgetrc
dillo                   ld.so.cache        opt             rsyslog.d         wicd
dnsmasq.conf            ld.so.conf         os-release      RTIMULib.ini      wpa_supplicant
dnsmasq.d               ld.so.conf.d       PackageKit      samba             X11
dphys-swapfile          ld.so.preload      pam.conf        sane.d            xattr.conf
dpkg                    letsencrypt        pam.d           securetty         xdg
emacs                   libaudit.conf      papersize       security          xml
environment             libblockdev        passwd          selinux
exports                 libibverbs.d       passwd-         sensors3.conf

Sounds like maybe you have “wait for network upon boot” disabled perhaps.

To see current setting::

sudo raspi-config nonint get_boot_wait

To enable it (what you need I believe):

sudo raspi-config nonint do_boot_wait 1

A bit more context:

https://forums.raspberrypi.com/viewtopic.php?t=320383

thank you very much for your help.
i ran the command: sudo raspi-config nonint get_boot_wait
and I received a response of “1”.
I guess this means that “wait for network upon boot” works?

It means you should already have the expected files, but don’t for some reason. Not sure. Maybe some weird upgrade in the past?

You can check out the link I posted as well as search around on the Pi forum. It’s come up there before.

thank you very much
I posted a message here
https://forums.raspberrypi.com/viewtopic.php?t=355048