Update impossible via updater


#1

Hi there,

I am facing updating problems of my Nextcloud instance. I am trying to update from version 13.0.2 via the built-in updater. My instance is hosted on a webhoster. The Apache version is Apache HTTPD 2.2.x . The used PHP version is 7.2.

Support intro
Nextcloud version (eg, 12.0.2) : 13.0.8 (and in testing environment 12.0.8)
Operating system and version (eg, Ubuntu 17.04) : n/a
Apache or nginx version (eg, Apache 2.4.25) : 2.2
PHP version (eg, 7.1) : 7.2 (and in testing environment 5.6)

Steps to replicate it:

  1. click in administrator account on “Basic settings”
  2. click on “Open updater”
  3. updater site opens, all check boxes are already positivley checked
  4. click on “Continue update”
  5. immediately the button “Go back to your Nextcloud instance to finish the update” appears
  6. click on the button redirects to “Files” of the administrator account

I am not able to break out of this loop. It seems the update is not downloaded via the updater. I checked the file browser of my webhosting intance and no Zip file has been downloaded. The version I am trying to update to is irrelevant. A few weeks/months ago I tried to update from 13.0.2 to 13.0.8, today I tried to update to 14.0.4 and the “loop” is still present.

I also have a testing Nextcloud environment with version 12.0.9 (with PHP 5.6). I tried to update to 13.0.8 but the update fails the same way I described above. Unfortunately I do not have any logging information available for both installations.

It seems that the problem is located at my webhosting partner. But this is just a guess. Have you some ideas/hints for me to solve this problem?

Cheers


#2

Same issue here.

Support intro
Nextcloud version: 14.0.4
Operating system and version: CentOS 7
Apache or nginx version: Apache 2.4.6
PHP version: 7.3

I don’t think it’s a problem of the webhosting partner, since I can do a manual download perfectly fine.

Greeetings
and thx @campfire to open this thread.

as you can see, all checks are already positively checked even before starting the download:


#3

Update:

I tried to update my new testing environment which is version 15.0.1 to a new daily release and it worked. In my opinion my webhoster is not the point of failure. Does someone have any advice for solving my update problem on my production environment?