Update from Nextcloud 18.0.8 to 18.0.9 not possible

Nextcloud version (eg, 18.0.2): 18.0.8
Operating system and version (eg, Ubuntu 20.04): DSM
Apache or nginx version (eg, Apache 2.4.25): 2.4
PHP version (eg, 7.1): 7.4

The issue you are facing: When I click on “Updater öffnen”, all the green ticks are already there and the update cannot be carried out. How can I fix this?

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Open Updater

The output of your Nextcloud log in Admin > Logging:

chmod(): Operation not permitted at /volume1/web/nextcloud/lib/private/Config.php#245

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '...',
  'passwordsalt' => '...',
  'secret' => '...',
  'trusted_domains' => 
  array (
    0 => '...',
  'datadirectory' => '/volume1/data/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '...',
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '...',
  'dbpassword' => '...',
  'installed' => true,
  'default_language' => 'de_DE',
  'default_locale' => 'de_DE',
  'knowledgebaseenabled' => false,
  'allow_user_to_change_display_name' => false,
  'skeletondirectory' => '',
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'enable_previews' => false,
  'theme' => 'custom',
  'updater.release.channel' => 'stable',
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '..',
  'mail_smtphost' => '...',
  'mail_smtpport' => '25',
  'maintenance' => false,
  'loglevel' => 1,
  'trusted_proxies' => 
  array (
    0 => '...',
  'forwarded_for_headers' => 
  array (
  'overwritehost' => '...',
  'overwriteprotocol' => 'https',
  'lost_password_link' => 'disabled',
  'filelocking.enabled' => false,

The output of your Apache/nginx/system log in /var/log/____:

There is no access to it.

The updater looks like this when you call it up. So far, all updates have been installed without any problems, but this time the update cannot even be started.


No real idea. But perhaps you can control or set the “step” in …/nextcloud/data/updater-****/.step . Can you access with the command line and use occ (ssh-access)?

I’m running Nextcloud on a Synology DiskStation. But yes I can access the folder with SSH. There is no .step-file. Even with ls -a it is not listed.

Why do you not make the update from the command line?

sudo -u www-data php updater.phar
(use correct paths e.g. /path/to/nextcloud/updater/updater.phar)

I can’t run the updater as www-data, it is called http on this system, because this user can’t use SSH. Whren I I tried it with my user or as root I got the following error message: Failed to open stream: Permission denied in phar:///volume1/web/nextcloud/updater/updater.phar/lib/Updater.php on line 1101. Could not open updater.log. But there is no file updater.log. If I add an empty file called updater.log in volume1/web/nextcloud/updater/ and adjust the permissions I get the same error.

I almost got it. But from command line all the green ticks are already there too. How can I reset this?

I deleted the .step-file and was able to perform the update. Thank you very much for your help.

Hi @Geronimo82,
Would you mind telling us how you solved this problem? Getting the same error now with v20.0.8

There is perhaps a file
You can test to rename/delete the file. Make a backup of the file.