Update from an old NextCloudPi version to a former version than to the current one

ncp
#1

Is it possible to update from an old NextCloudPi version to a former version than to the current one? For example: Version 1.11.2 is installed. The current version is 1.12.3. But I would like to update to version 1.11.5 because the update to the current version fails. Which is the correct command?

sudo ncp-update …?

#2

Downgrading is not supported, if that is what you mean.

sudo ncp-update

will update to the latest available version, NextCloudPi v1.12.3, presently.

If the update fails, you should look for what is causing the failure.

Look at output of ncp.log or run ncp-report to find out what is going wrong.
I usually copy/paste to pastebin or similar and share link here, for long reports.

#3

Hi, thanks for the answer. I’ve this problem but nobody answers: https://help.nextcloud.com/t/cant-update-nextcloudpi-sub-process-usr-bin-dpkg-returned-an-error-code-2/52937
I don’t want to downgrade. I only want to upgrade to the next version except the current one. Just step by step from one version to the other. Not from 1.11.2 directly to 1.12.3 but from 1.11.2 to 1.11.5 to 1.12.0. Then, if everything works well from 1.12.0 to 1.12.3…

#4

that’s not possible as of today, but something similar will come to be more gentle with people that skip important updates

#5

Ok. I already installed the whole system again with version 1.12.3. Now I wait until Nextcloud 16.0.1 is available via panel by choosing “0”. I don’t want to install it directly by typing “16.0.1” because there might be new problems.
nc16