Update from 24.0.6 to 25.0.0 loops, as does 25.0.2

I apologize in advance for the lack of details. I have scoured the logs and I don’t really see any mention of a failure.

Description of Problem
Originally I upgraded from 24.0.6 to 25.0.0 back in October. After the upgrade completed, it reported everything was successful but each time you visit the GUI, you would be prompted with the app update required page and it would say that it is going to update workflowengine. After clicking the upgrade, it performs all of its steps and reports no errors. After completion, it goes right back to the same page stating that it is going to update workflowengine again.

Currently workflowengine is at version 2.6.0 and I can tell that it should be 2.7.0.

Important Details

  1. I have reviewed all of the logs from both nginx and php error.log and there are not any errors being logged. I know that files are being updated though, as I do see them updated I start/stop the container.

  2. I have also checked the nextcloud.log file and no errors are being logged there.

  3. Connectivity inside the container to the public Internet validates fine and I am able to access all important Nextcloud public URLs via cURL.

  4. Not having much time to look at this, I shelved the upgrade in hopes that maybe it was a slight upgrade bug and it would be resolved in a later version. Today I have upgraded to 25.0.2 and I am still seeing the same behavior.

  5. I have scoured the https://help.nextcloud.com forum looking for similar issues but I have not been able to find anything that I believe is similar to my issue.

Attempted Steps

  1. I have attempted to run from the CLI ./occ upgrade and receive similar results.
  2. I have tried enabling all installed apps to ensure that an app that was previously disabled wasn’t causing a problem.
  3. I have also tried disabling every possible app hoping that an installed app might have been causing the problem.
  4. I have tried the following commands as well.
    a. db:add-missing-indices
    b. db:add-missing-columns
    c. db:add-missing-primary-keys
    d. db:convert-filecache-bigint
    e. Strangely, a command that I used to run now returns an error saying it is no longer valid, files:cleanup. This might be intended, but not 100% certain.
  5. I also tried manually upgrading the workflowengine app by invoking ./occ app:update workflowengine which doesn’t return any output, but the version still stays at 2.6.0.

Current deployment is dockerized using the lsio base image. Docker host is a physical x86_64 based Rocky Linux 8.5 system. Backend database is currently postgres 13.9-1.

I am happy to provide any command output or configuration files, but I have decided not to make this initial post 100 pages long with a bunch of needless information.

Thanks for any tips or suggestions that I can explore.

Just checking to see if anyone has any thoughts on this?

I’ve encountered this issue as well going to 25 and again with another update. Looks like something in the DB is broken and I still haven’t managed to fix it

My current work-around:

  1. php occ app:list - get the current version of workflowengine
  2. edit apps/workflowengine/appinfo/info.xml change the version tag to the current version i.e. <version>2.8.0</version>
  3. Re-run php occ upgrade

I’ve ended up just manually updating the version number in the DB. Don’t know if this is a great idea or not but I’ll see in the long run.

  1. docker exec -it nextcloud_db bash
  2. psql -U nextcloud -d nextcloud
  3. UPDATE "oc_appconfig" SET configvalue = '2.9.0' WHERE TRIM(BOTH FROM appid) = 'workflowengine' AND configkey = 'installed_version';