Update from 21.0.7 not possible - server-side-encryption / 4-byte characters

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version: 21.0.9
Operating system and version: Linux 5.15.32 x86_64
PHP version: mysql Version: 10.2.36

The issue you are facing: “Open updater” get’s me to top of the “Security & setup warnings” and a lot of lines are shown, two of them in orange:

  • MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL. For further details read the documentation page about this.
  • The old server-side-encryption format is enabled. We recommend disabling this. For more details see the [documentation]
  1. line: I cannot enable MySQL 4-byte support with the help of the documentation, because I do not have permission to do any “sudo” commands. I have installed nextcloud (in 2017) as a “one-click-application” (1-Klick-Anwendungen) provided by my hoster (manitu.de)

  2. line: I cannot disable the server-side encryption, the checkbox is grayed out.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Administration → Overview → Open updater

Any advide on how I can update my nextcloud?