Update from 1.16.1 NCP

Good evening!

I got the messange, that I shoud upgrade my nextcloudpi from 1.16.1 to 1.16.4

now I get:
Downloading updates
Performing updates
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
php7.3-gmp is already the newest version (7.3.4-2).
0 upgraded, 0 newly installed, 0 to remove and 75 not upgraded.
updates/1.17.0.sh: line 26: /etc/systemd/system/fail2ban.service.d/touch-ufw-log.conf: No such file or directory

i tried the update in the nextcloudpi Panel and per ssh.

Schmidt

I met the same problem.
My NCP 1.16.0 shows 1.16.4 available. After the web base NextCloud Panel did not update NCP properly, I went to ssh and got the same message.

here exactly the same

Similar issue upgrading. I receive this trying to upgrade via ssh after web ui failed.

NextCloudPi v1.16.1 is outdated
update to v1.16.4 through 'ncp-config' or type 'sudo ncp-update'
You have new mail.
Last login: Sun Sep  8 16:43:53 2019
root@nextcloudpi:~# ncp-config
Downloading updates
Performing updates
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists... Done
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

This topic should probably be listed in appliances?
https://help.nextcloud.com/c/support/appliances-docker-snappy-vm

I have the same issue. Can someone help me on this .

Issue: “updates/1.17.0.sh: line 26: /etc/systemd/system/fail2ban.service.d/touch-ufw-log.conf: No such file or directory”

Confirmed - same issue.

My original image is ‘NextCloudPi_11-04-18’

now it work’s

THANKS

Fixed - thank you

Has anyone a Solution ?

I spin arround

I tried it today again and it works

It’s Not possible to Update to 1.16.6 ,

Where it’s possible to look in log, so i Can post.

Im going Crazy

This was fixed, I think, run

sudo ncp-update

to update to ncp v 1.16.6
(ncp v.1.17.0 should be available shorly)

Checked documentation concerning staying up to date?

I have try this, it doesnt work