Update fails due to folder "tmp" on hosted webserver

Hi folks,

having had an error in the past regarding files not being previewed in the cloud or - even worse - not even getting synchronised at all, I came across the recommendation to add a folder “/tmp” in my nextcloud installation and adding the following to the config.php:
‘tempdirectory’ => ‘/path/to/installation/tmp’,
This suggestion has been made, as I cannot access my php.ini (it’s a hosted webserver).

Now, when I try to update the cloud, I get an error message:

## Check for expected files

The following extra files have been found:

* tmp

… now what?

Many thanks and kind regards,

Place the /tmp directory somewhere else outside of the Nextcloud root directory,
because there is now way to get the directory excluded from the internal check.

1 Like

That solved it - thanks :slight_smile:

1 Like

Hi j-ed
can you please be more explicit with it?
I already had (and have) my temp folder set in /etc/php/7.3/fpm/php.ini and /var/www/nextcloud/config/config.php set to the external HD where my data also is: /media//nextcloudtemp
however, I keep getting the same error.
I have made some preview updates within version 17 without problems. Now that I move to 18, I get the problem.
I also noticed that a folder names tmp is present in several other location (/tmp and /var). but is not referenced in any variable that I know of in Nextcloud. (I assume is for the rasbian os??)
Even if I try to temporarily rename those tmp folders, it wont work. and in the / (root), it simply gets recreated.

Does Nextcloud add temp folder references elsewhere?

Make sure that you remove any existing tmp folder in the Nextcloud document root (/var/www/nextcloud) and the message should disappear.

Other directories outside the Nextcloud document root are not checked by the relevant function.

It might be possible that the web updater has created the temp folder in the Nextcloud document root, but due to the fact that I’m not using the function I cannot double-check nor confirm it.