Update errors 14.04-15.07

I’m stuck here:

Authentication

To login you need to provide the unhashed value of “updater.secret” in your config file.

If you don’t know that value, you can access this updater directly via the Nextcloud admin screen or generate your own secret:

php -r ‘$password = trim(shell_exec(“openssl rand -base64 48”));if(strlen($password) === 64) {$hash = password_hash($password, PASSWORD_DEFAULT) . “\n”; echo "Insert as “updater.secret”: ".$hash; echo “The plaintext value is: “.$password.”\n”;}else{echo “Could not execute OpenSSL.\n”;};’

Secret
Login

Hi all, I’m trying to run a planned update - I fail with the above.

Additionally, when i run the command susggested, I don’t get the upgrade secrect updated.

I got as far as dleeted files, then hit an error that we could not get past - I ended up browsing to Servername/Nextcloud/updater only to be greeted by the above.

Nextcloud 14 (Upgrading to 15)
Ubuntu 17.04
PhP 7.2
Apache 2.4?

No log, as i have to move and delete that before upgrading.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '******',
  'passwordsalt' => '********',
  'secret' => '***************',
  'trusted_domains' =>
  array (
    0 => 'Domain.com',
    1 => 'domain.com/nextcloud',
  ),
  'versions_retention_obligation' => 'disabled',
  'log_type' => 'owncloud',
  'logfile' => 'nextcloud.log',
  'loglevel' => 1,
  'logdateformat' => 'F d, Y H:i:s',
  'htaccess.RewriteBase' => '/nextcloud',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
  ),
  'datadirectory' => '/var/www/html/nextcloud/data',
  'overwrite.cli.url' => 'mynextcloudserver',
  'dbtype' => 'mysql',
  'version' => '14.0.6.0',
  'dbname' => '****',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '****',
  'dbpassword' => '******',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'PLAIN',
'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
  'mail_from_address' => '****',
  'mail_domain' => '******',
  'mail_smtphost' => '********',
  'maintenance' => true,
  'updater.release.channel' => 'stable',
  'updater.secret' => '****This does not update*****',
);

Anyone have any ideas here? I need to re-plan the update

If you are on your own server, you can easily do it over command line (less risk to run into a timeout):

sudo -u www-data php /var/www/html/nextcloud/updater/updater.phar