Update error 18.0.3

I got this error: https://we.tl/t-pEkVAr2atK

What to do now

Error is also in ssh if i do ./occ upgrade

Please follow the basic rules of courtesy and write a detailed description of your problem, including information about your hardware and software environment and versions and also provide a step-by-step description how to reproduce the problem.
An excerpt of the Nextcloud and web server log file would also be helpful.

The provided link doesn’t work, therefore please upload images to your request and don’t link it to external sources which might vanish after a while.

BTW, have you already tried to use the search function to find an answer on your question? Many users are reporting similar issues therefore a chance exists that you an answer/solution has already been provided.

1 Like

i cant paste the error, if i do it my browser is crashing

But here, a tiny example

e3479bc6497a90c864b4361f59f24a44cd6eb236b5e37efb8565450e343cd80ec8",“current”:“c7b43e904122ed6853bd3304fe74a1874b301e87b435209249cf62e8137a6c047e61e980528592d048b3a74750f94b2469c8ffd49dc7c35e1526b8c441776726”},“3rdparty\/aws\/aws-sdk-php\/src\/data\/comprehend\/2017-11-27\/api-2.json.php”:{“expected”:“34d16dd5b8451118d4590400c4a46ef1d79a717182bad1d1ef3829d67e15974824436060332ad00e1447ddbf5aeeee9dc8bbb404b8118b85a59611838097dbda”,“current”:“5370d8dea151bd9aeb3912620d5b9c695a286a214eeb85dcdbcb20cc8bd94174c2103c05d33176c53f0f98989bba2cebffb31cf6be8605e7e397414554038612”},“3rdparty\/aws\/aws-sdk-php\/src\/data\/docdb\/2014-10-31\/api-2.json.php”:{“expected”:“f3fe71d2506a026b88348b75121d6d5334a62242a4bdebf89fd102a631300b007732ffb3ddd5641807c80659fc7233aac1758befbd4b6f7fc1c8e8a99b999b08”,“current”:“2c1b6eb73aa8f5b3dfa03ab057ac328776b307e5087d6b7cdadcc920fd7a28e8721511f2530c5cbac879910d951c1491b339c12f7df412d44ee428eaaa99ac8d”},“3rdparty\/aws\/aws-sdk-php\/src\/data\/kinesisanalytics\/2015-08-14\/api-2.json.php”:{“expected”:“d29ee994099c837b8e7ea3a8f4393e44a42d377e91a91ee3c565aa7966294fe8c62d1ec3ca7f336c77087d499797f9f8de136e14a8d7e385159824f2ec5fc100”,“current”:“8473c4ac090fa51174bdf81f6169725fdcbb964f0843cdd15a4fe7e8fecd83967596e10bd34e2b10c6b57b7bfa54fd91aa39444392507e0cf93e52da9c7401f8”},“3rdparty\/aws\/aws-sdk-php\/src\/data\/route53\/2013-04-01\/api-2.json.php”:{“expected”:“f37fb159eba004594a7e114d60eaa30bdb3c1a2aa935a40e93186bb13d14cef0c0dcfceb3bb8a07f72e9b833e932fed152ab373dc2e1948457c8638de95c4c0f”,“current”:“bc94d832d4ec3abc1fea8a67186060f1110537368154e4b694f70bf23a3efb536bcac0cc639a5fa806c0932fb32732856241660c901052fc5c949b1063343299”}}}}", “core”, “oc.integritycheck.checker”]:

SQLSTATE[08S01]: Communication link failure: 1153 Got a packet bigger than ‘max_allowed_packet’ bytes
Update failed
Maintenance mode is kept active
Reset log level

Nextcloud version: 18.0.3 if i update
Operating system and version (eg, Ubuntu 17.04): webhost (directadmin) I think centos
Apache or nginx version (eg, Apache 2.4.25): nginx 1.10.0
PHP version (eg, 7.1): 7.3

cant find any other topics what can help me…

Already tried this?

I hope you have a backup of your Database and Installation.

Euhmmmm no??? ;( only installation

Ow database isnt changed for now i think thats save. But how to fix is this the host?

First you need to backup your database, second you could make changes to your mysql configuration as described in the stackoverflow answer (https://stackoverflow.com/a/104176/13106166). It’s just a guess, I’m no expert but I would give it a try as long as everything is backed up.

i think i can begin the installation again…

logging page dont work anymore, userpage doesnt work anymore, accessibility, there is a error with the data folder that says that ocdata is not in the folder but it is in the folder…

No backup? :confused:

idk of the database.
But i think a reset is better

Well, it certainly is the cleanest solution. But sooner or later you will encounter the database issue again, so maybe you should do some research on why this is happening.

database max_allowed_packet have the host been updated to 20mb
it was on 10mb

when i upgrade it to 20mb it updates perfectly but because i was testing serveral things i think i have some files overwrited, and maybe the update have also changed the database but i dont know.

Clean install should be fine i think and do that tomorrow i think

Ah OK, then the change of upload limit was the solution for your initial problem. :+1:

Could you mark one of the posts above containing the solution as “solution” so other users with the same problem can find it more easily?