Update doesn't update

I have a neat / interesting little problem. if i try to update the version 21.0.4-> 0.5 the checks perform all is done but no change happens. i tried the web-interface also, it does the same: all checks are marked allready (at the moment i start) , the update runs, reload and i’m still on the old version.

It is like an dry-run.

php occ status

  • installed: true
  • version: 21.0.4.1
  • versionstring: 21.0.4

Steps to replicate it:
Update (web / CLI)

php updater/updater.phar
Nextcloud Updater - version: v20.0.0beta4-11-g68fa0d4

Current version is 21.0.4.

Update to Nextcloud 21.0.5 available. (channel: "stable")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-21.0.5.zip
Open changelog ↗

Steps that will be executed:
[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[✔] Downloading
[✔] Verify integrity
[✔] Extracting
[✔] Enable maintenance mode
[✔] Replace entry points
[✔] Delete old files
[✔] Move new files in place
[✔] Done

Continue update? [y/N] Y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[✔] Check for expected files
[✔] Check for write permissions
[✔] Create backup
[✔] Downloading
[✔] Verify integrity
[✔] Extracting
[✔] Enable maintenance mode
[✔] Replace entry points
[✔] Delete old files
[✔] Move new files in place
[✔] Done

Update of code successful.

Should the "occ upgrade" command be executed? [Y/n] Y
The current PHP memory limit is below the recommended value of 512MB.
Nextcloud is already latest version

Keep maintenance mode active? [y/N] N
The current PHP memory limit is below the recommended value of 512MB.
Maintenance mode already disabled

Sounds frustrating. Could you please provide some more stats, such as PHP version and how nc was originally installed: Docker, Snap, etc.? See the support category template for helpful info you can share.

Support Template

Nextcloud version (eg, 20.0.5): replace me
Operating system and version (eg, Ubuntu 20.04): replace me
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): replace me

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Not frustrating interesting.

This instance is a vServer , an Ubuntu, directly installed non docker/snap/jail variant.
PHP at CLI 7.4 , at Web 8.0.10 with an apache (version hidden/tomcat). also tried different php versions same result.

Have a look at this topic. Looks similar to me…

nice find.

Jepp, i tried that and after renaming (i don’t deleted them for compare) both .step files the updater becomes working normal.

THX