Update checker gets stuck on an old version


I use an up and running home server, since approx. 2 years. It runs on a raspi 4, default ubuntu-withoutXserver version.

The nextcloud updater worked until 21.0.4. From 21.0.4 version, the update checker was always indicated : “current version 21.0.4, update avalaible : 21.0.4”. Running the online updater, the message was “no update avalaible”. I’ve decided to do a manual update ( following https://docs.nextcloud.com/server/latest/admin_manual/maintenance/manual_upgrade.html), and did the jump to 22, then 23. Everything is ok, server is now up, running the 23. version.

My only problem is the update checker still gets stuck on 21.0.4. Here is a screenshot : Capture d’écran du 2022 01 22 09 16 42 — Postimages
If I try to run the update, I just get the message : " Current version is 23.0.0. No update available."
I’ve tried command line update-check, no way to resolve that.

Is there any way to get the online update-checker working again ?

edit : the https://scan.nextcloud.com/ tester detect an old version :
Running Nextcloud
NOT on latest patch level

Thanks in advance ;

Most of the time it helps to rescan in the update checker. It caches old results and will not rescan automatically.